red LED blinking twice repeatedly after upgrade

I ugraded 2 das ago from v142 to v143 and i noticed the red led on my orange PI that blinks twice, repeatedly, is it bad news ?
I didn’t notice this behavior previously, that’s why I think it is strange. After installation of dietpi on my orange pi , I verified that o had the v142 installed and the red led didn’t blinked.


I also have to mention that I had samba working (on v142, before I wiped the SD out and. Fresh install, followed by NFS share, then formated the HDD I have it running with to ext4 partition and then I didn’t knew how to working around things to configure it properly, so I changed it to proftp).
After that, it became inconvenient to have it that way, and I changed it to samba, and I cannot inderstand why I don’t get neither my android phone or my PC to connect it to the samba share .
I read about sharing a ext4 through samba, and it it supposed to work, at least from what I read on Ubuntu forums.

Yes, the heartbeat-like red led blinking was added to all boards with the H3 chip on board in V143

I also have to mention that I had samba working (on v142, before I wiped the SD out and. Fresh install, followed by NFS share, then formated the HDD I have it running with to ext4 partition and then I didn’t knew how to working around things to configure it properly, so I changed it to proftp).
After that, it became inconvenient to have it that way, and I changed it to samba, and I cannot inderstand why I don’t get neither my android phone or my PC to connect it to the samba share .
I read about sharing a ext4 through samba, and it it supposed to work, at least from what I read on Ubuntu forums.

Yes it should work, but have you set it up properly?

Alright, thanks for the info .

Yeah, it should, and it did, the problem was only on my home network configuration.
Thanks once again.

Hello
Is there a way to stop red ligth blinking? I think it’s not usefull…

thanks in advance

Hi,

These are the commands we use to activate it:

			echo -e "heartbeat" > /sys/class/leds/*red*/trigger & #OPi one
			echo -e "heartbeat" > /sys/class/leds/*blue*/trigger & #NanoPi M1

Not sure exactly what the command for off/none is, you can check available modes with:

cat /sys/class/leds/*red*/trigger
cat /sys/class/leds/*blue*/trigger

Then example:

echo -e "none" > /sys/class/leds/*red*/trigger
echo -e "none" > /sys/class/leds/*blue*/trigger

Hearbeats are standard on Odroid, great indicator for when device is operational. We like it, and will roll out to all boards we can.

Hi,



root@OrangePi-One:~# cat /sys/class/leds/red_led/trigger



none mmc0 mmc1 timer [heartbeat] backlight default-on

Example: Turn off

echo -e "none" > /sys/class/leds/red_led/trigger

But this setting do not survive a reboot.

So done a guide, what you can do and how to make changes persistent: https://dietpi.com/forum/t/orangepi-one-change-function-of-red-status-led/1084/1

cu
k-plan

Hi,

Legend, thank you :slight_smile:

so… my orange pi keeps forgetting the configuration i chose after each reboot … anyone gets this behaviour as well ?
my configuration is : green LED off, and the red one with heartbeat.
after the reboot, the green LED is on all times, and the red , starts blinking normally

Hi,

Please can you paste results of:

cat /DietPi/dietpi/.dietpi-led_control
uname -a
cat /DietPi/dietpi/.version

Is this OrangePi PC?

Is this OrangePi PC?[/quote]
Yes

please , keep in mind that this is the result of cat, without me rebooting the unit and therefore, the results could be different after me rebooting (aka when the green led forgets that it should be off)

root@greenland:~# cat /DietPi/dietpi/.dietpi-led_control
green_led none
red_led heartbeat
root@greenland:~# uname -a
Linux greenland 3.4.113-sun8i #18 SMP PREEMPT Thu Jun 15 02:16:06 CEST 2017 armv7l GNU/Linux
root@greenland:~# cat /DietPi/dietpi/.version
152

[edit]
ok… , i rebooted, to give also about when it happens, and it is the same output

root@greenland:~# cat /DietPi/dietpi/.dietpi-led_control
green_led none
red_led heartbeat

but i assure you the green led comes on and never goes off as is should be, if you want, i videotape it and mail it to you

Confirmed, looks like a bug in the OPi Kernel.

LED control pulls its current values directly from /sys/class/leds. This is telling us that “none” is active, however, it appears the LED gets stuck on “always on”. Changing from “none” to “anything else” then back to “none” seems to resolve it.

Not much we can do about this one as kernel is provided by ARMbian. We’ll have to wait for a fix in their kernel updates via apt.

ok, thanks, i will be waiting patiently for it then :mrgreen:

My configuration, with green led always on and red led blinking works perfectly on both my OPi PCs, after multiple reboots.
I assume the problem lies in the [none] option only?