Reboot / halt not working


I have some trouble updating my raspberry pi 3. When I have to reboot, it does nothing, just hang there… :smiley:

It’s the same thing with halt command…

To have a proper reboot, I have to unplug the raspberry, but the update doesn’t apply.

Anything I can do? I tried a few google searches, without any luck… :thinking:

Hi shlagwuk,

are you really “root” user? Doesn’t look like that for me (missing '"#" ). “>” looks like C-shell not like bash.

Can you please try:

root@dietpi3:~# whoami

root@dietpi3:~# sudo reboot

# or

root@dietpi3:~# sudo su

# and now

root@dietpi3:~# reboot

# or 

root@dietpi3:~# poweroff

Thanks for your answer!
Yes, I am root, I may have played my PS1 a little bit :wink:

root@dietpi3 ~ > whoami

The strange thing is that it was working well before… never had any problem with reboot or halt commands :frowning:

As I cannot reboot, any change I make with dietpi-config or to /Dietpi/config.txt are note saved… (with reboot -f, it doesn’t save :thinking: )

So I’m stuck into headless mode… anything I can do te get out from headless mode?


 sudo su

# and then


What happens now?

Please a Screenshot from htop:


Is your bash/terminal running as root?
If so, your SD-card / file system may be corrupt.

Take the first screenshot from DietPi Desktop running x-server or per vnc?

Sorry but insufficient information.

I tried. Nothing… :neutral_face: I can’t try without ssh (on a screen plugged into the pi), because it’s stuck in headless mode.

Yes, I’m logged with root user.

I’ve got the same issues and there was no solution to this, any ideas?

do you have a screen you could attached to check what happen on the shutdown command?

Same issue on PizeroW

Could you go through to above asked questions, and is it with SSH or on screen? And how long did you wait? It is possible that some hanging service hangs shutdown sequence for up to 90 seconds, similarly a hanging service can hang the boot sequence for up to 90 seconds. A default systemd timeout, so give it at least that time to see whether this is the issue.