RealVNC/desktop/user woes

I’m having some issues with using realvnc as a remote display.

First, I want to be able to use a non-root user with realvnc. If I understand correctly, the service files should be what I edit to enact this change by running under a non-root user. However:

dietpi@TerraPi:~$ ls -la /etc/systemd/system |grep vnc
dietpi@TerraPi:~$ ls /etc/systemd/system
apt-daily-upgrade.service               dietpi-cloudshell.service           dietpi-postboot.service.d    display-manager.service  ifupdown-pre.service.d       serial-getty@ttyAMA0.service
apt-daily-upgrade.timer                 dietpi-firstboot.service            dietpi-preboot.service       getty-static.service      serial-getty@ttyS0.service
apt-daily.service                       dietpi-fs_partition_resize.service  dietpi-ramlog.service
apt-daily.timer                         dietpi-kill_ssh.service             dietpi-vpn.service 
dbus-org.freedesktop.timesync1.service  dietpi-postboot.service             dietpi-wifi-monitor.service  ifup@.service.d

dietpi@TerraPi:~$ sudo systemctl status | grep vnc
             │ ├─371 /usr/bin/vncserver-x11-serviced -fg
             │ ├─372 /usr/bin/vncserver-x11-core -service
             │ ├─527 /usr/bin/vncagent service 0
             │ ├─550 /usr/bin/vncserverui service 0
             │ └─586 /usr/bin/vncserverui -statusicon 0
             │ ├─1068 grep vnc
               └─370 /usr/bin/vncserver-virtuald -fg

Also when I connected to realvnc as root, at first I got a “cannot connect to display”/“display is unavailable” error message. This was after connecting to a headless install. I then installed a desktop session (lxde if I am not mistaken), reboot, and was then able to connect to a desktop. I thought that realvnc created a virtual session?

dietpi@TerraPi:~$ grep "VNC" /boot/dietpi.txt
# VNC Server

how did you install RealVNC? Did you used dietpi-software? Usually, our software script will install a desktop automatically.

I used apt to install realvnc, and I used the software manager to install lxde.

pls go into dietpi-software and install RealVNC. This should install everything needed.

I don’t see RealVNC as an option for the Odroid C2, only Tiger/XRDP/NoMachine. Is it possible to add RealVNC back to the software bundle for Linux DietPi 6.0.13-meson64 #22.11.2 SMP PREEMPT aarch64 GNU/Linux? Tiger has known issues with screen blanking when running earlier versions of JDK I need.

ok you are not running an RPi device. An information you could have shared on the troubleshooting template you ignored.

On non-RPi device, we disabled RealVNC because it requires a license to be added and is not free like on RPi device.

I have a license @Joulinar and would like to run RealNC.

ok but if I understood RealVNC is running now? And yes, a desktop is required to be installed. At least it needs to be available but not necessary started. This is same on our RPI implementation, there we install a desktop as well.