Realtek 8188 Wi-Fi Adapter Kernel Panic

Hi.

I got a strange problem with a USB Wi-Fi adapter based on RTL8188.
The SBC is Orange Pi PC. The dongle is bought from official Orange Pi store (Shenzen Xunlong Inc. or something)
After loading kernel modules for this dongle, kernel crashes.
I can’t provide the logs because i got no serial cable.

I tried to google your dongle and board you are using and MANY others are having this problem.
Easyest solution would be to use another wireless stick. But you can get it to work with this module https://github.com/pvaret/rtl8192cu-fixes found in the ARMbian Forum https://forum.armbian.com/index.php?/topic/1770-orange-pi-pc-wireless-rtl8188cus/

When i built it on my Orange Pi PC (through installing *.deb from notebook because my router is crap, all is Jessie/armhf/sun8i) (system is Armbian), it throwed errors. I tried to build https://github.com/pvaret/rtl8192cu-fixes and https://github.com/dz0ny/rt8192cu and it throwed this errors: https://hastebin.com/raw/eyitoroyuv

Seems cheap to google your error messages, but i hope in the end it helps or we get the final spark :smiley:

He has the same issue as you and this might be a way to solve it? https://forum.armbian.com/index.php?/topic/749-orange-pi-pc-wireless-module-8192cu/&do=findComment&comment=14551

If this is giving out new error’s, post 'em again :slight_smile:

Thanks! It’s compiling and even working! But, there’s one small problem: after some time, it crashes.

Does the whole board crash or just the module / stick?
Is there any log you can provide? :question:

  1. Board crashes fully.
  2. I can’t provide logs because i don’t have a serial cable

What is your board loading?

cat /etc/modules-load.d/modules.conf

and

lsmod

Here’s the link: https://hastebin.com/raw/foyikagaha
EDIT: I think that it’s a problem with particular driver.

Maybe we are hunting the wrong driver for the device? Some vendors throw the same device on the market but with different chips. :roll_eyes:

What does lsusb say about your wireless stick? :question:

To rule everything out, what power cable are you using on your device (Volt and Ampeere)?

So, here’s what lsusb says about my Wi-Fi stick:

Bus 003 Device 002: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter

The USB cable is official, from Orange Pi AliExpress store. The charger is Greenheart (from Sony Ericsson Xperia Mini), outputting 5 Volts and 850 mA.

Are there by any chance 2 modules active in your system?

find -L /lib/modules/  -name 8192cu.ko | awk '{ print "ls -lt "$1 }' | sh

and some other things i noticed are; in in cat /etc/modprobe.d/blacklist-rtl8192cu.conf eingetragen “blacklist rtl8192cu” ?

Maybe disabling power saving in the device: in /etc/modprobe.d/8192cu.conf

options 8192cu rtw_power_mgnt=0 rtw_enusbss=0

Other than this im nearly out of my knowledge and a fresh start of compiling and installing dietpi would make a success :frowning:


\


Some info in other forums where saying that you would need a minimum of 2A power for the OrangePi and some/this stick to work (explained by the fact, that the kernel would only give out kernel panic. The system crashing meaning a ‘unstable’ / not enough power :neutral_face:

Hmm… The results are disappoiting.
Here’s the output of first command:

-rw-r--r-- 1 root root 843516 Jun 14 03:29 /lib/modules/3.4.113-sun8i/kernel/net/wireless/8192cu.ko

All other commands have been failed with message: No such file or directory (except nano, it said that file didn’t exist and sayed that it will create a new file).

those files, if they are not there, then create them pls :slight_smile:

You did reboot your device yourself here or there, when crashed by editing files, check the saved things, could always be gone :exclamation:

Okay, i created /etc/modprobe.d/8192cu.conf. All is the same. It crashes after some time (usually 10-30 seconds). I think it’s a memory bug. Or, as you said, it can be power bug.

Thanks for help! The crashing after some time was a problem with power brick. I took a 5 V and 1.5 A USB charger and it worked like charm! :slight_smile:

Nice to hear this! :smiley: