RBPi 4 + Transmission - Unable to save resume file: No space left on device

Hello everybody
i was happily using my radarr + transmission combo on my RBPi 4 until this error occurred

According to this post RPI2 - No space left on device seems like transmission is saving data on SD instead of using USB (mnt/diethd)

Any help?

After rebooting all files go back live, but as time passes the error pops up again -

Tried this

sudo nano /etc/transmission-daemon/settings.json

changed these lines
“incomplete-dir”: my USB HD
“incomplete-dir-enabled”: true,

started to run the service again but got this error

root@DietPi:~# sudo service transmission-daemon start
Job for transmission-daemon.service failed because the control process exited with error code.

See “systemctl status transmission-daemon.service” and “journalctl -xe” for details.
root@DietPi:~# systemctl status transmission-daemon.service

● transmission-daemon.service - Transmission BitTorrent Daemon
Loaded: loaded (/lib/systemd/system/transmission-daemon.service; disabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Tue 2020-12-01 16:59:05 GMT; 12s ago
Process: 6088 ExecStart=/usr/bin/transmission-daemon -f --log-error (code=exited, status=1/FAILURE)
Main PID: 6088 (code=exited, status=1/FAILURE)

Dec 01 16:59:05 DietPi systemd[1]: Starting Transmission BitTorrent Daemon…
Dec 01 16:59:05 DietPi transmission-daemon[6088]: [2020-12-01 16:59:05.203] JSON parse failed in /var/lib/transmission-
daemon/.config/transmission-daemon/settings.json at pos 569: SPECIAL_EXPECTED – remaining text "# “download-queu”
Dec 01 16:59:05 DietPi transmission-daemon[6088]: [2020-12-01 16:59:05.203] transmission-daemon Error loading config fi
le – exiting. (daemon.c:693)
Dec 01 16:59:05 DietPi systemd[1]: transmission-daemon.service: Main process exited, code=exite
d, status=1/FAILURE
Dec 01 16:59:05 DietPi systemd[1]: transmission-daemon.service: Failed with result ‘exit-code’.
Dec 01 16:59:05 DietPi systemd[1]: Failed to start Transmission BitTorrent Daemon.

Tried to reboot but Transmission not loading
● transmission-daemon.service loaded failed failed Transmission BitTorrent Daemon

In the meanwhile

  • I cancelled a few incomplete files and the error didn’t occur anymore
  • i checked what was going on with /root and found out that the /var folder had 24G

so I run
root@DietPi:~# du /var -h --max-depth=1

4.0K /var/mail
4.0K /var/local
24G /var/lib
16K /var/spool
26M /var/cache
860K /var/tmp
14M /var/www
1.2M /var/log
1.4M /var/backups
4.0K /var/opt
24G /var

and with a more in depth search

24G /var/lib/plexmediaserver

so it seems like transmission stops because Plex is filling up to much space in the SD card


could be plex is going to store stuff for transcoding? Maybe you should consider to move your whole RootFS to an external HDD. This would be recommended anyway to reduce r/w operation on your SD card. Or you move the whole system into a HDD and get ride of the SD card at all.

Maybe you can search for the largest files on your system

du -a / | sort -n -r | head -n 20

According to Plex forum it’s a common problem - I’m trying to move Plex Library to the HDD https://forums.plex.tv/t/moving-pms-library/197342

Anyway I always thought that booting up from SD was faster and less error-prone - am I wrong?

But it might be the right move as right now it won’t boot if the HDD is disconnected anyway - probably because userdata are on HDD, or there’s another explanation?

Usually it should boot, but services might fail if they depend on user data directory. Basically you could have your entire system located on a SSD and should be quite fast.