Raspi 5 with Dietpi 9.0.2 & port issue

Creating a bug report/issue

I have searched the existing open and closed issues

Required Information


  • Power supply used | [
    GeeekPi Raspberry Pi 5 Netzteil 27W, 5V 5A USB C Power Supply, PD 27W Power Adapter für Raspberry Pi 5 4GB/8GB

  • SSD 250 Gb used |

Additional Information (if applicable)

Fresh install on the ssd and applied the patch for usage with Raspi 5. All outstanding upgrades applied. This is my testrig , just to see if everything works. I installed a few apps i.e Ampache / RPI-Monitor /Linuxdash / webmin / Dietpi-Dashboard.
And surprisingly not everything works as planned. After checking and checking I noted that it has something to do with the open or better closed ports. Only these are marked as open.

Meaning that webmin / rpi-monitor are working,but Linuxdash and Dietpi-dashboard not.
Ampache is working for the browser , but not for mobile clients.
All this is Lan only. On my standard device ( Raspi 4 / Dietpi ) 9.0.2 everything is working well. Any idea on what is going on ? Additional required ports need to be opened manually ? If so how ?
Tks for any input

there is nothing to be open related to ports, as long as you don’t use a firewall software. If a port is not present, the related service is not running. Means you need to check each of the missing services what the issue might be.

For DietPi Dashboard, you would need to use the latest nightly build as the stable version is already known to fail on RPi5.

Hi, tks that clarifies the matter a bit. One more question , since I’m not so familiar with Github , where can I find the nightly builds ?


Just run a reinstall for DietPi Dashboard and you should be ask which version to choose. Nothing needs to be done on GitHub.

Hi, tks a lot. At least this problem is solved :grinning:

Have a nice day

Feel free to open separate topics for other issues

I had the same issue when I was attempting to install DietPi Dashboard on my RPi5 which has a fresh install. But… When I tried to use the nightly build, it failed and asked me to update the command.

Is this a known issue and is there a potential resolution?

Check dietpi-dashboard.service: Failed with result 'signal'. · Issue #763 · ravenclaw900/DietPi-Dashboard · GitHub

Awesome! Thanks so much