Raspberrypi touchscreen on Rock4SE

Search turned up nothing.
So, I just installed dietpi on my new Rock4SE and have been trying to figure out how to enable my official Raspberry pi 7" touchscreen. I tried it with the Debian11 OS and had no problem getting it going, but the OS kept locking up. There’s too much KDE on that image anyway. So I tried Dietpi, thinking I would have no problem enabling the touchscreen with a simple overlay, like in Debian, but it’s not there.

Any help would be appreciated. I like this lightweight OS for a sbc, but I have to get the touchscreen working.

what kind of overlay you are missing? Maybe @MichaIng could have a look.

The Radxa image you mean? That uses an ancient 4.4 vendor kernel which cannot be compared to our mainline Linux 5.15 kernel build. But indeed the mainline kernel does not support all the customisations Radxa adds to their kernels.

Checking the Armbian forum (as we use their kernel packages):

Looks like someone needs to figure out and create a device tree overlay which works with mainline Linux. Sadly, even that the ROCK (Pi) 4 is officially supported, it seems the maintainers mostly ignore topics from non-paying users, so it’s about experienced other community members.

Thanks for the response. It surprises me a bit that this issue hasn’t come up before with the rock4 and its various flavors. It is a near drop-in replacement for the rpi 3-4 (at half the current price) with very few minor adjustments needed in the associated device housings. Since I had the touchscreen working with the Debian 11 OS offering, it’s evident that the hardware is capable.

The debian OS has a configuration UI named “rsetup” in which they offer a number of overlays to select from, one of which is the rpi 7" touchscreen. After selecting it and rebooting, the screen came right up and needed no calibration. That indicates to me there is a configuration file somewhere that might be adapted to the dietpiOS, as both OSs are debian linux based. I don’t have a lot of experience, but I guess I’ll do a little dinking around and see what I can figure out. This is not a critical case, just a project I have been working on for a long time…my rpi4B died, so now I’m starting over with the Rock4SE.

As said, what you find on Radxa’s Debian images is a very outdated and highly customised Linux kernel, and tools/options which are highly integrated with this specific kernel build. All this cannot work on recent mainline (official) Linux versions without someone writing the needed overlays.

“Debian-based” does not mean much in this regards, as this refers to userland tools only, not to the kernel, device tree, overlays, etc. This has all nothing to do with Debian, and the same Radxa kernel with those tools/overlays would work on any other Linux distribution.

To get an idea about the needed device tree changes, there are two ones form Radxa for at least Linux 5.10 (but I’ve no idea if those were ever tested and functional, since AFAIK, the official Radxa Debian image is still Linux 4.4):

So its about enabling DSI and I2C1 and adjusting some ports. But there is also this raspits_touch_ft5426 node, where I’m not sure if this needs to exist in the original device tree already, whether it needs a dedicated kernel driver, and whether both is present in the mainline kernel. And of course all the symbols/phandles are likely different and need to be looked up e.g. in /proc/device-tree/__symbols__/.

Thanks for that reply. That will help. I have copied the .dtbo file I found in the raxda debian OS and that, along with what you provided should get me started. It will be a good learning experience (or a very frustrating one) for me to learn how overlays are made and executed.