Raspberry PoE-HAT Fan Speed

Hi all

I have a Raspberry Pi 3B+ with a PoE-HAT.
The HAT has a fan on it.
On raspian it’s possible now to control the speed with a config-parameter in the config.txt:
This turns on the fan @ 55C°.
I have tried this on dietpi, but i think it does not work.
Should this work or not?

Thx an greetings

DietPi uses the official Raspberry Pi kernel and firmware, so yes this should totally work.

The board communicates to the HAT via I2C, so you need to enable it, e.g. via dietpi-config > Advanced Options > I2C state
Or temporarily to the running system:

dtparam i2c_arm=on

Check if this enables the kernel module automatically:

lsmod | grep 'i2c-dev'

Otherwise enable manually:

modprobe i2c-dev

The following should then show the active I2C device:

ls -Al /dev/*i2c*

Thank you very much for your reply.

The short version:
It works out of the box. You don’t need to activate i2c module.

The longer version:
It was my “fault”. The pi was in a “closed case”. So there was no real airflow. Because of this, the temp was always high and i thought the config parameter is not working (fan was always on). Now i made some holes in the case to make an airflow possible.
And tata, it is working now!
Sometimes it is better to sleep one night over it then asking right now in the forum. :roll_eyes:

Ah okay perfect. Yeah the fan should be at best included into the case, so have it’s own whole where it sits inside. Also smaller wholes are very suboptimal, limiting the airflow.

Here that you get an idea how this should look like:

No so easy, it is a PoE-Powerd Control-Unit to control my audio system and video survey :wink:

This case has normal no holes. And maybe it is not designed to work with PoE :roll_eyes:
But hey, it’s a pi-project! So everything is allowed :rofl:

Ah yeah forgot again that it’s about the fan on the HAT and not on the Pi itself. Not sure about additional heat of the PoE HAT but since it comes with fan and fan speed stays high closed case, it seems to be required.

You could run cpu to check temps and see if it is okay with your current solution. Generally if there is already a fan, its airflow path should be as free as possible. Closing it too much could even lead to better without fan than with, since the fan itself also consumes power => produces heat :wink:.

Hi everyone

I have a Raspbeyy Pi 4 whith 4Gb of RAM and i have installed a POE Hat after that does not connect on eth0 or wlan0 if i remove it all works fine. do think a driver is missing?

does the board is powering up at all? Means led’s flashing? Are you able to attach a screen to check what going on?

hi again. Yes, the system is up an funcional whit keyboard and monitor but can’t link over eth0 or wlan0

can you have a look to dmesg and journalctl if you see some messages regarding the network interface. What happen if you run ifup eth0

here the messanges

ifup eth0
ifup: interfece eth0 already configured

ip addr
1: lo
2: eht0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 100
link/ether dc:a6:32:a6:13:e6 brd ff:ff:ff:ff:ff:ff
inet brd scope global eth0
valid_lft forever preferred_lft forever
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 100
link/ether dc:a6:32:a6:13:e7 brd ff:ff:ff:ff:ff:ff

hmm looks like your system is not detecting the network cabel plugged because you have eht0: <NO-CARRIER
. Does it change anything if you do ip link set dev eth0 up?

i do not change anything even if i connect the cable without POE and plug UBS-C with power… all works right, eth0 wlan0.
all without remove the poe hat, even i try with 2 different

So if I understood correctly, It’s working without PoE-HAT only. As soon as the PoE-HAT is plugged, it’s not working anymore. Do you have a spare SD card? Would it be possible to test with plain Raspberry OS?

the POE-HAT is allways connected when i put energy by POE the ports eth0 and wlan0 do not work, if i connect cable lan without energy and plug USB-C with energy the ports eth0 and wlan0 works right. I will try with other distro

pls keep us posted how it’s working on plain Raspberry OS.

hi, again

I was install Raspbian and all work right, with POE-Hat eth0 and wlan0 work fain

Maybe MichaIng has an idea what the issue could be.

Do you use the 32-bit or 64-bit image and can you please paste the full kernel log: dmesg
I was searching a bid and indeed it seems to be not required to enable the I2C overlay/parameter, means it should work OOTB. However that is relevant for the fan only.

Also kernel is up-to-date? apt update && apt upgrade

Hi, again

In last days i was try ti make work the POE HAT with differente OS in my raspberry pi 4, i was try with Ubuntu, Rasbian, Dietpi, etc. but it do not work.
The fan works right but in all cases the eth0 is down and i can’t do make work.