Raspberry Pi 4 Boot from SSD

Now Raspberry Pi 4 bootloader Support Boot from USB, i use dietpi with SSD and Boot from SD Card, can i now pull SD Card Out?

Sry my english…


many thanks for your request. No, you can’t simply remove the SD card because it contains the Boot File System. First you would need to ensure to have latest Raspberry Pi firmware installed. If this is the case, we recommend to flash an actual DietPi image directly to the SSD drive and to boot from SSD right a way.

What would be sweet is to have a VERY tiny /boot SD card .img (say around 100-500mb)

Then inside the /boot it points to the rest of the OS, so it will boot the kernel, then attach to the rest of the OS on the MUCH faster SSD

This way smaller cheaper even slower SD cards can be used to boot the device but then it fstab’s to the OS on the main drive which is much faster/larger, as for removing the SD card…nah…

OK thanks for the information :smiley:

pls let us know if it was working to flash the image directly to SSD and boot from it. As this is quite a new functionality on Raspberry OS, it would be good to have some success stories :wink:

FYI, I’ve been running dietpi directly from my SSD plugged into my USB3 port on my Raspberry Pi 4 4GB for about 2 months now. It’s worked like a charm.

Just had to make sure I was running the latest bootloader software, then I used my normal image writer to write the dietpi image to the ssd (just as I did many times with sdcards), plugged the ssd into my USB3 port… pulled out the sdcard, and pressed power.

It has worked flawlessly.

many thanks for sharing, good to know that it is working now.

I tried to copy my Dietpi installation on SD to SSD (through an image obv) but no way to boot from it. Also I have the latest firmware and the controller is fully compatible with this, read on a guide.
Did you follow a particular guide? Do I have to install a fresh dietpi on SSD? Any other suggestion?

sudo vcgencmd bootloader_config

sudo rpi-eeprom-update

[sudo] password for admin:
BCM2711 detected
Dedicated VL805 EEPROM detected
BOOTLOADER: up-to-date
CURRENT: Thu Sep 3 12:11:43 UTC 2020 (1599135103)
LATEST: Thu Sep 3 12:11:43 UTC 2020 (1599135103)
FW DIR: /lib/firmware/raspberrypi/bootloader/default
VL805: up-to-date
CURRENT: 000138a1
LATEST: 000138a1

You can have a look at following guide https://dietpi.com/forum/t/raspberrypi4-rpi4-upgrading-from-existing-sd-card-setup-to-boot-from-ssd/4555/1

Hey I have a similar issue. I followed your guide and the SSD 128GB is recognized by the system. I could mount it and benchmark it. But after flashing the image (no errors) and starting up the pi nothing happens?!
What am I missing?
I attached the lsusb when booting from micro sd and drive is mounted. If the micro sd is missing nothing happens. I’m not able to ssh into the machine.

I was able to boot from the original micro sd in an as card reader so I suppose it’s an issue with the usb sata cable right?

Would it be enough to move roots via drive manager to the ssd? I don’t care if the initial boot is via micro sd but the programs should run on the ssd (especially emby)

Help is highly appreciated.

Flashing the SSD with DietPi and booting to SSD worked for me - RPi4

I did have Raspbian installed before, so updated the bootloader first and set the options correctly before flashing the SSD.

yes indeed you can move RootFS to SSD only and keep BootFS on MicroSD

Same here for a few months…

thx for sharing. :slight_smile: