Raspberry Pi 3 - Wifi adapter "not found"

I installed Dietpi on a Pi 3 a few months ago, and probably disabled the wifi adapter at the time, as the pi was cabled.

Recently I thought I’d use it on wifi instead, but when I run dietpi-config, and go to network adapters, the status of the wifi is “not found | disabled | disabled”

If I attempt to enable it, Nothing happens, and even after a reboot the adapter is still “not found”.

If I look, /dev/wlan0 does not exist.

I saw that the changelog for dietpi 145 fixed a problem with wlan on p3, so I updated to this but I still have the problem - I cannot enable wifi.

(To ensure that the Pi 3 wasn’t faulty, I tried a fresh install of Dietpi on another SD card, and was able to enable wifi successfully there).


Can anyone help me to find out what is wrong with my existing installation,


Is there a way I can create a new Dietpi installation and then (automatically?) copy over my chosen Dietpi programs (eg transmission) along with settings and files etc?

Many thanks


Hi Ian,

Are you by any chance overclocking SD?

cat /DietPi/config.txt | grep sd_overclock

If that returns a value, overclocking SD will break WiFi/BT on RPi 3. Needs to be removed.

If not, let us know.

Hi, thanks for the reply.

No, I’m not overclocking SD, and that grep returns nothing.

As far as I recall, I’ve only made changes using the dietpi menus, ie to originally switch the wifi off. And the Pi 3 is running at standard clock speeds, no overclocking of any kind.



Hi Ian,

Thanks for the info.

We’ll need to get additional information on your system.

With WiFi enabled in dietpi-config. Please can you send us a bug report (instructions below)?

Thank you for your help.

I have submitted a report, the ticket is 21399fab-13ca-463b-8f40-42462e6d734a-0
(although I thought I saw a “not sent” or similar message flash on the screen before I was presented with this message!

Cabled networking is working fine on the pi3.

I attach a screenshot of the setup menu where I cannot enable the wifi module.

Many Thanks


Thanks Ian,

I’ll take a look and get back to you.

Hi Ian,

I’ve noticed you are using the testing branch for this installation (v145). The testing branch is active devolpment, potentially unstable and should not be used by end users (aside from testing future updates).
Due to the nature of the testing branch (always changing, updating, fixing and sometimes breaking things on purposes for testing), it would be impossible to debug this current installation as we have no way of knowing which state its in.

I would highly recommend staying with the master branch (default stable), and reinstalling this device which should give you DietPi v144 currently.
Please let me know if WiFi issues continue on this new installation.

Thank you for the reply.

I hadn’t knowingly chosen the testing branch, so I’m a bit puzzled by that, but it’s entirely possible I did it by accident!

Yesterday, I did install a fresh copy of diet-pi on a different SD card, and I can report that it is all working fine there. So I shall stick with that.

Thank you for your help


No worries. Although, we cant rule out if I may of left testing in dietpi.txt for v142 image by accident :wink: