Raspberry Pi 3 Stuck on Reboot after mounting Samba server

Hi all!
I’m new to the DietPi Forum community but have used dietpi for about a year or so and love it! thank you to the whole DietPi team for such a great distro!

I’ve been having trouble with rebooting my raspberry pi 3 (using sudo reboot) when I mount a network drive Samba server using the dietpi-drive_manager. when I try to reboot it seems to be stalling, but when I go to physically unplug the pi then plug it back in, to boots up just fine. the reboot functionality works just fine when I unmount the samba server. I suspect that there might be something funky going on with the fstab file but not sure what. any help is appreciated! thank you!!

Have you tried

#shutdown -r now

Also try reboot -f.

Hmm, never used samba but will try to investigate if/why it prevents reboot.
When you use dietpi-drive_manager on current v6.14 then the fstab should be recreated/updated. So fstab is the reason, then we need to check/identify/remove the faulty e.g. samba mount argument.

hello,
thanks for the help. I tried both reboot alternatives and it had the same effect. Below is the fstab entry generated by dietpi (username and password omitted of course. :slight_smile:
thanks again

//192.168.1.1/storage /mnt/nighthawk cifs username=XXXXX,password=XXXXX,iocharset=utf8,vers=3.0,_netdev,nofail 0 0

bumping this post. does anyone else have this issue?
Thanks again!