Raspberry PI 1 B Model Issues with Media

ok let’s try to have it started manually

cd /mnt/dietpi_userdata
sudo -u jellyfin /usr/bin/jellyfin --webdir=/usr/share/jellyfin/web --restartpath=/usr/lib/jellyfin/restart.sh --ffmpeg=/usr/lib/jellyfin-ffmpeg/ffmpeg

if all goes well, you should see the server log passing by

Thanks for reply, Put that straight in and came up with a segmentation fault what ever that means.

root@DietPi:~# cd /mnt/dietpi_userdata
root@DietPi:/mnt/dietpi_userdata# sudo -u jellyfin /usr/bin/jellyfin --webdir=/usr/share/jellyfin/web --restartpath=/usr/lib/jellyfin/restart.sh --ffmpeg=/usr/lib/jellyfin-ffmpeg/ffmpeg
Segmentation fault

Searching online the fault people say its a corrupt sd card, but it cant be as qbittorrent works just fine, and its a fresh install and does it every flash. Could it be because its a PI 1?
Just testing Pi Hole also works fine…

Indeed it could be an issue of Jellyfin not being able to run on RPi1 boards. I have similar behaviour on my RPi1 test system. Probably they did not support armv6l ???

MichaIng any ideas

Found it:

sed -i 's/debian/raspbian/' /etc/apt/sources.list.d/dietpi-jellyfin.list
apt install --reinstall jellyfin jellyfin-ffmpeg

They have a dedicated ARMv6 (Raspbian) repository now. I’ll implement this in our case as well.

Fixed with: https://github.com/MichaIng/DietPi/commit/b80185a8a07d4fe5c0f0a0ae3353731204bf8623
Changelog: https://github.com/MichaIng/DietPi/commit/a0ea9775458e8e109fd40a9fe9da56ff9652100b

I am running dietpi on RPi0W
I modify my diepi-software as per below changes

installed jellyfin and did a reboot
i cant access jellyfin webpage. looked under services (in dietpi-launcher) and found service failed to start. Restarted service but no use.
Any suggestions…

probably easier if you would try DietPi 6.34 BETA :wink:

anyway, can you post following

cd /mnt/dietpi_userdata
sudo -u jellyfin /usr/bin/jellyfin --webdir=/usr/share/jellyfin/web --restartpath=/usr/lib/jellyfin/restart.sh --ffmpeg=/usr/lib/jellyfin-ffmpeg/ffmpeg

dietpi@DietPi:~$ cd /mnt/dietpi_userdata
dietpi@DietPi:/mnt/dietpi_userdata$ sudo -u jellyfin /usr/bin/j
ellyfin --webdir=/usr/share/jellyfin/web --restartpath=/usr/lib
/jellyfin/restart.sh --ffmpeg=/usr/lib/jellyfin-ffmpeg/ffmpeg

We trust you have received the usual lecture from the local Sys
Administrator. It usually boils down to these three things:

#1) Respect the privacy of others.
#2) Think before you type.
#3) With great power comes great responsibility.

  1. Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

[sudo] password for dietpi:
Sorry, user dietpi is not allowed to execute ‘/usr/bin/jellyfin
–webdir=/usr/share/jellyfin/web --restartpath=/usr/lib/jellyf
in/restart.sh --ffmpeg=/usr/lib/jellyfin-ffmpeg/ffmpeg’ as jellyfin on DietPi.

can you do this as root user pls

root@DietPi:/mnt/dietpi_userdata# sudo -u jellyfin /usr/bin/jellyfin --webdir=/usr/share/jellyfin/web --restartpath=/usr/lib/jellyfin/restart.sh --ffmpeg=/usr/lib/jellyfin-ffmpeg/ffmpeg
Segmentation fault

below is my edited ditepi-software

software_id=178 # Jellyfin
		if (( ${aSOFTWARE_INSTALL_STATE[$software_id]} == 1 )); then


			# Install APT repo key
			#G_EXEC eval "curl -sSLf '$INSTALL_URL_ADDRESS' | gpg --dearmor -o /etc/apt/trusted.gpg.d/dietpi-jellyfin.gpg --yes"
			G_EXEC eval "curl -sSfL '$INSTALL_URL_ADDRESS' | gpg --dearmor -o /etc/apt/trusted.gpg.d/dietpi-jellyfin.gpg --yes"

			# Install APT repo
			#echo "deb https://repo.jellyfin.org/debian/ $G_DISTRO_NAME main" > /etc/apt/sources.list.d/dietpi-jellyfin.list
			local distro='debian'
			(( $G_HW_ARCH == 1 )) && distro='raspbian'
			echo "deb https://repo.jellyfin.org/$distro/ $G_DISTRO_NAME main" > /etc/apt/sources.list.d/dietpi-jellyfin.list

			# Install Jellyfin + FFmpeg implementation
			G_AGI jellyfin jellyfin-ffmpeg


did you tried running DietPi 6.34 BETA?

Changed master to beta in /boot/dietpi.txt

Did update from dietpi-launcher
Reinstalled jellifin, dietpi-software reinstall 178
But still jellyfin service failed under dietpi-services

hmm I did a test on my RPi1 and indeed it’s still failing. Strange. Ok we would need support from developer on this MichaIng

hmm I tried to follow instructions on jellyfin.org, but it seems armv6l boards are not supported anymore. I did not tested it but maybe running on Docker might be an alternative. :thinking:

Docker does work…I installed it on my OPiPC…testing now (however it is based on the newest kernels not the older RPiB armv6l kernels)

It should work just fine…this is the docker run jellyfin.sh I made

docker run -d \
 --name jellyfin \
 --user 1000:1000\
 --net=host \
 --volume /home/warhawk/jellyfin/config:/config \
 --volume /home/warhawk/jellyfin/cache:/cache \
 --mount type=bind,source=/home/warhawk/jellyfin/media,target=/media \
 --restart=unless-stopped \

It is up and running…testing by copying a movie over to the /home/warhawk/jellyfin/media directory…however I think I may create a mapping to my main UNRaid server to see if it can go thru my vast library on my main server

I did have to use portainer to re-create the docker file because I screwed up the user flag before and had to “tweak” it to get it working

Can you verify that the Raspbian Jellyfin repo has been installed as expected: cat /etc/apt/sources.list.d/dietpi-jellyfin.list
This should have been fixed with the first beta already: https://github.com/MichaIng/DietPi/commit/b80185a8a07d4fe5c0f0a0ae3353731204bf8623
If that does not support armv6l, then the repository is worthless as any other architecture can use the Debian Jellyfin repo.

I did another test on my RPi1B running DietPi v6.34.3. Jellyfin is failing

root@DietPi1:~# systemctl status jellyfin.service
● jellyfin.service - Jellyfin Media Server
   Loaded: loaded (/lib/systemd/system/jellyfin.service; disabled; vendor preset: enabled)
  Drop-In: /etc/systemd/system/jellyfin.service.d
   Active: failed (Result: signal) since Mon 2020-12-21 13:17:10 CET; 28min ago
 Main PID: 397 (code=killed, signal=SEGV)

Dec 21 13:17:10 DietPi1 systemd[1]: jellyfin.service: Service RestartSec=100ms expired, scheduling restart.
Dec 21 13:17:10 DietPi1 systemd[1]: jellyfin.service: Scheduled restart job, restart counter is at 5.
Dec 21 13:17:10 DietPi1 systemd[1]: Stopped Jellyfin Media Server.
Dec 21 13:17:10 DietPi1 systemd[1]: jellyfin.service: Start request repeated too quickly.
Dec 21 13:17:10 DietPi1 systemd[1]: jellyfin.service: Failed with result 'signal'.
Dec 21 13:17:10 DietPi1 systemd[1]: Failed to start Jellyfin Media Server.

root@DietPi1:~# sudo -u jellyfin /usr/bin/jellyfin --webdir=/usr/share/jellyfin/web --restartpath=/usr/lib/jellyfin/restart.sh --ffmpeg=/usr/lib/jellyfin-ffmpeg/ffmpeg
Segmentation fault

And, as above check, the package is definitely installed from the Raspbian branch of the repository?

Get:3 https://repo.jellyfin.org/raspbian buster InRelease [6637 B]
Get:4 https://fra1.mirror.jellyfin.org/debian buster/main armhf Packages [1639 B]
Fetched 8276 B in 6s (1464 B/s)

Seems to be fechted from debian?? But source list looks fine

root@DietPi1:~# cat /etc/apt/sources.list.d/dietpi-jellyfin.list
deb https://repo.jellyfin.org/raspbian/ buster main

Oh… their mirror director does not respect the Raspbian/Debian separation. It seems that https://repo.jellyfin.org/raspbian is redirected to https://fra1.mirror.jellyfin.org/debian while https://fra1.mirror.jellyfin.org/raspbian would be actually available :roll_eyes:.

I just reported it: https://github.com/jellyfin/jellyfin-meta/issues/5

Okay, sad fact: Jellyfin cannot run on ARMv6 boards, i.e. Raspberry Pi 1 and Zero models. This is an issue with .NET core itself: https://github.com/dotnet/runtime/issues/7764
The “raspbian” repo directory only exists so that $( awk -F’=’ ‘/^ID=/{ print $NF }’ /etc/os-release ) from the downloads page can be used on Raspbian as well, but it is a symlink or internal rewrite to the Debian binaries anyway, so does not mean its Raspbian armv6hf binaries.

So we need to disable the install option on those boards. But to be clear, a media server on RPi 1 or Zero would anyway not be of joy I guess, unless it’s for SD videos or audio only :wink:.