Raspberry 4: HDD (over USB) does not reconnect on reboot

Recently I have purchased Raspberry 4 B.
I have next setup: SATA 2.5" HDD is connected to USB3 port using SATA-to-USB connector. See attached.

When I boot to DietPi, HDD is available at /dev/sda1 and it may be mounted as expected.
When I reboot DietPi (with HDD connected), the volume is not present (/dev/sda - is present, but /dev/sda1 - is not) and not mounted.
When I do a cold start (power off and then power on), the disk is mounted and everything works as expected.

Does anybody have an idea about the reasons for this behavior?

The interesting facts about this situation:

  1. It does not matter which port I connect (USB2 or USB3)
  2. The most INTERESTING!!! I also have Raspberry 3 B+. When I insert the same sd card and the same HDD disk to Raspberry 3 B+, everything works as expected. Disk is remounted on every reboot/after poweroff.

It looks like HDD is sent to some kind of sleep during the boot process.

I do not think it is a power-related issue:

  1. It works with Raspberry Pi 3B+ board, which uses USB2 ports power (which is less than power over USB3 in Raspberry Pi 4B).
  2. Previously I have used (without any issues) exactly the same HDD with exactly the same SATA-to-USB connector at my TV with USB2 port and no additional power.
  3. I have tried to power independently my HDD from external 2.0A USB charger using the other side of this Y-type SATA-to-USB connector. It didn’t help.
  4. I have tried to power up Raspberry Pi 4B with USB Type C 3.0A power adapter and over GPIO connector from another board (with 5V 4.0A power adapter).
  5. Based on the review of my drive (https://www.storagereview.com/node/1237) it uses about 2,5Watt at the peak times. I am not sure is it much or not.
  6. I have also tried another 2.5" HDD. And the behavior is absolutely the same.


I am having the same problem with my USB external hard drive which is powered by wall socket.

Any thoughts anyone?

My guess is that it’s something to do with a quirk of the adapter, power requirements, or something to do with waiting for the drives to spin-up after spinning down.

I’m now booting/rebooting from an M.2 SSD just fine on a pi4. I also have an externally powered 3.5" HDD.

Hi guys, can you please test to disable UAS:

echo -e 'blacklist uas\nblacklist sg' > /etc/modprobe.d/disable_uas.conf

It’s a known plague that some drives do not support UAS, which is enabled by default on RPi4 but disabled on previous models, respectively RPi4 uses a different USB driver which supports UAS, hence the kernel loads the modules automatically.

Via USB quirks in /boot/cmdline.txt it can be disabled/blacklisted for single USB drives, but I am thinking to disable it all together since I didn’t read about a single case where it is required or very beneficial but only multiple reports about failing USB drives. As long as there is no proper quirks/black"list" maintained for the kernel, this seems to be a trial and error often, not something I am keen to ship for end users long-term.

Totally fixed it! Thanks so much. Will let you know if I experience any issues with it.

Great, thanks. I’ll also raise the topic about UAS and the underlying USB driver at RPi GitHub.