Radxa Rock5B: Looking at the thermal threshold to kick in the fan

Hi, I got a Rock5B from Radxa and installed dietpi on it.

I was testing that everything is working on it which include checking the fan.

TLDR: Couldn’t turn on the fan by heating up to 72 degree celcius (>60 for at least 10 minutes). I confirmed the fan is working. Trying to figure out if the support for that board is completely missing or if it could be just a bad configuration for my board. But I have no clue where to look for.

Required Information



Linux rock5b 5.10.110-rockchip-rk3588 #23.02.2 SMP Fri Feb 17 23:59:20 UTC 2023 aarch64 GNU/Linux

Fresh install without any additional softwares yet.

Extra details (Details of all I know)

I turned the board on and… no fan. Well, the CPU is cold (30 degree celcius) so it may be in a quiet zone.

I started the stresstest and end up at 49 degree celcius. Still no fan. Fine, let try something else. I was able to heat it up up to 62 degree. Still nothing. I’m currently writing this post (slowly) while it is at 62 and no trace of the fan running.

I tested the fan with external power, it is good.
I looked online to find the GPIO to toggle manually (16) (Technically: PWM1_M0 or GPIO0-C0) and yep, it start running. So the connection are fine.

I found DietPi/dietpi-fan_control at db683273c34f39b2d55e5927a5c9c9b5c1a0acd4 · MichaIng/DietPi · GitHub which list a file in /boot/dietpi/.dietpi-fan_control. I also found a path to /usr/bin/dietpi-fan_control ( Post with id 14337, post number 8 ). On my end, I couldn’t find anything. A post of around nthe same time as the post with id 14337) post said it may be for the PI and was still in development. I also tried to find some other path in /sys/devices/platform/ without finding anything close to.

I found /sys/class/thermal/ but I’m not yet in a state to say anything about it yet. It list 4 devices and 7 zones. (4 devices match the number of cores of the CPU)

I also found https://www.kernel.org/doc/Documentation/devicetree/bindings/thermal/rockchip-thermal.txt which talk about some configuration. But I have no clue where it could be if it exists.

One thing I saw in the log:
[ 13.382647] rockchip-thermal fec00000.tsadc: Missing rockchip,grf property
[ 13.383210] rockchip-thermal fec00000.tsadc: tsadc is probed successfully!

To finish, the stresstest is still going on: 68 degree and no fan.

EDIT: I also found, in /boot/config-5.10.110-rockchip-rk3588, some configuration aroudn FAN that “aren’t set”: