Radarr hardlinking and samba

I have an NVIDA Shield running a plex server and it has transmission on it to handle torrents. I got dietpi running with Radarr (not a docker). I have one of the HDDs connected to the shield remotely mounted to the pi through samba

All in all things work. Radarr moves the torrent file to transmission BUT it copies it into the specified folder I set. No hardlinking. The user and group for the /mnt/path/ I setup is dietpi:dietpi.

When I tried to manually create my own hardlink in the mount it fails with permission denied. I’m assuming this is Radarr’s issue as well. So…is there a way to solve this?

can you share some more details. What kind of link you create? Source? Target? File system permission of target folder?

So the overall problem is Radarr cannot create a hardlink on the smb mounted drive that’s setup on the dietpi.

This means that Radarr is, gigabyte by gigabyte, copying data over to another folder. So I tried to see if I could create a hardlink on the mount as you can see here:

/mnt/movies is a SAMBA share? Can you share following

 cat /etc/fstab

Basically SAMBA share is not that good solution, because SAMBA did not support Unix file system permissions at all.

my bad I had just assumed it’s samba because of the drive manager setup

Maybe you need to check on SAMBA server side if links are supported. Another option is to check mount options on client side. linux - Clients can't create symlinks on Samba share - Super User

Anyway, if possible try to use NFS :wink:

Yeah I don’t think I can mess with anything on the Nvidia Shield related to making the drive accessible over the network so it can’t run a NFS server. And if by client side you mean the dietpi…the drive manager doesn’t have any mount options for networked drives.

So…I;m guessing what I want to do is impossible

so what’s different between this thread: Read/Write access denied with mounted drives?

and my thread? We’re both using networked shares?

You already mount the SAMBA share using 777 permissions. Means, full access. Your issue is with creating links which might be a challenge on SAMBA

As stated on the link above, on client side try to manually adjust mount options inside /etc/fstab. Just need to keep in mind, drive manager will revert them next time you open drive manager again (unfortunately).

CIFS and SAMBA are the same thing? If you mean changing the 0770 permissions in the fstab file to 0777 then I’ve already tried that :cry:

yes CIFS and SAMBA are the same.

No this is not what I mean. This has nothing to do with it. Your issue still, that you are trying to create links on SAMBA. Which is not working ootb. Therefore, I shared linux - Clients can't create symlinks on Samba share - Super User There is an accepted answer describing a soft option, which can be set within client mount option. This might allow to create links. If not, you might need to search the web on how to create/use links on SAMBA.

lol I think what you’re trying to tell me is to use the command line to mount and not the drive manager. I’m green, bro. Gotta spell shit out but yeah those are symlinks though. Radarr doesn’t do symlinks it tries to create hard links

Sounds like, though. Shit just ain’t gonna work. I guess the solution is ‘ain’t gonna work’

theoretically you could have Transmission running on DietPi + connect your HDD. This should at least work around the SAMBA issue. You could export directories using SAMBA or NFS and have mounted on the NVIDA Shield.

Basically the other way around compare to current config.