QNAP NFS input/output errors copying any files


Hey there guys. Having an absolute hell of a time for a week now with my QNAP NAS that I’ve had mapped via NFS for quite a while working just fine.

Sometime in the night of 9/4 into 9/5, my Diet-Pi failed to read files off my NAS. I noticed something was wrong when all my music files suddenly had no cover art in DSub (running Airsonic on the Pi) and would never play, just flash like they were trying to. Essentially now all that happens is I can mount the drive just fine, cd and ls into it just fine but every time I try to copy any file, even just a blank test file I can create (so, write works) I get:

cp: cannot open ‘whateverfile’ for reading: Input/output error

Thinking my drive might be failing I did a full bad sector scan which took a whole night plus a filesystem check, everything was clear there. Rebooted both the NAS and pi several times, removed and readded the drive both with dietpi-drive_manager and manually, tried modifying my /etc/fstab with johnwick’s line from 2018 since I read he also has a QNAP, even went so far as to completely wipe the entire server/reimage and start from scratch last night thinking surely that would fix it. No dice. :frowning:

Not sure what else to try and this point aside from getting an entirely different board and going from there… the odd thing is, I can write to the drive as mentioned, and three other NFS clients both Raspbian and Windows-based have no problems at all reading from it.

If it helps I’m running an ODROID N2 on the latest version 6.32.2 and QNAP TS-231 with the latest firmware Anyone have any ideas? Pulling my hair out over here. Thanks much!


if I understood right, you already reinstalled your N2, correct? If yes, you could verify the behaviour on using a different image than DietPi. Just for testing purposes how it behave. An option would be using an Armbian image.


If the issue stays, it might be something with the board?

Another option would be trying to use SAMBA/CIFS ?
As well, check kernel messaged once the issue happen dmesg -l err,crit,alert,emerg
Plus, having a look to journal about related massages journalctl -n 100 --no-pager

Thanks for the reply! Interestingly, it works just fine using the Stretch image on my other ODROID, a C2. Also, I thought maybe something had updated on the night of 9/4 but both the QNAP firmware and DietPi update were the week or so prior, and things were working fine after that time as well.

My /etc/fstab looks like: /mnt/qnap nfs _netdev,nofail,noauto,x-systemd.automount

I checked in my QNAP settings and see it also supports NFSv4, so tried changing that in the fstab to nfs4 but no change.

Ok I just tried to copy a file over, got the same input/output error and dmesg shows:

NFS: server error: fileid changed
fsid 0:45:, expected fileid 0xf9da95, got 0x2bc0006

Tried copying the same file over on my Windows client, works just fine. As does the same thing on my other Odroid running the Stretch image with the same /etc/fstab entry.

Ran that journal command as well and that tells me:

nfsidmap[23793]: nss_getpwnam: name ‘guest’ not found in domain ‘localdomain’

uhh looks like a common issue using NFS. I simply copied your error into google and got quite some hits

NFS: server error: fileid changed
fsid 0:45:, expected fileid 0xf9da95, got 0x2bc0006

probably an issue with the nfs export file