qBittorrent not downloading

Hi, I set up qbittorrent reciently and it’s not download nor sharing any torrent, new or already material on disk. I change everything, open ports on router, nat upnp options, the same result. I tested installing transmission, and without any config applied it started downloading the same torrent…

The service is active.

I am newbie on linux, show if you want me to check anything, please help me a bit.

Thank you.


I did a test installation of qBittorrent, and without any configuration applied, I’m able to download a torrent. I used Raspberry OS image for my test.

I’ve used the Odroid HC4 image, I will try reinstalling to give it a try…

Thank you anyway, I will share the result

This is what I’m seeing on the trackers tab, no udp ulrs has connections, I’ve search that problem, and there are many post on official forums and reddit, maybe it’s some bug of that version?, I’ve seen I have 4.1.5 but on github the latest is 4.3.3, can someone tell me how to update, to check if is that?

I found following on qBittorrent Github page. They have a wiki entry for DietPi :slight_smile:


but it might not 100% fitting as it seems a little bit outdated.

Have tried, but gives an error compiling libtorrent on this command:

./configure --disable-debug --enable-encryption --with-boost-libdir=/usr/lib/arm-linux-gnueabihf --with-libiconv CXXFLAGS="-std=c++14"

Checking for boost libraries:
configure: error: --with-boost-libdir expected directory name

I will try on a new dietpi installation to check only with qbittorrent installed…

Because on deluge, it works, but some torrents are not resuming from already downloaded files…

did you installed all the dependencies? At least I was able to work around and to build 4.3.3


I follow all the steps until that one that gives that error… :roll_eyes:

what is the system your qBittorrent is running on. Is it a Raspberry Pi or something else?

It is and Odroid HC4

it’s a 64bit system right? uname -a

It seems:

Linux DietPi 4.9.241-arm64 #1 SMP PREEMPT Tue Jan 5 23:38:40 CET 2021 aarch64 GNU/Linux

ok let me test on a 64bit demo system. The guide on qBittorrent is based on 32bit system if I’m not mistaken

Ok, thank you so much for your patience…

it’s basically working as well for 64bit. At least on my RPi 64bit test system

I changed the ./configure lines on the guide

that’s what I did on an empty system (copied from my command line history :wink: )

apt install build-essential pkg-config automake libtool libc6-dev libboost-dev libboost-system-dev libboost-chrono-dev libboost-random-dev libssl-dev qtbase5-dev qttools5-dev-tools libqt5svg5-dev zlib1g-dev
cd /tmp/
wget https://github.com/arvidn/libtorrent/archive/v1.2.12.zip
unzip v1.2.12.zip
cd libtorrent-1.2.12/
./configure --disable-debug --enable-encryption --with-boost-libdir=/usr/lib/aarch64-linux-gnu --with-libiconv CXXFLAGS="-std=c++17"
make -j$(nproc)
sudo make install
cd ..
sudo nano /etc/ld.so.conf.d/libtorrent.conf
## add following and save file: /usr/local/lib
sudo ldconfig
export LD_LIBRARY_PATH=/usr/local/lib:${LD_LIBRARY_PATH}
wget https://github.com/qbittorrent/qBittorrent/archive/release-4.3.3.zip
unzip release-4.3.3.zip
cd qBittorrent-release-4.3.3/
./configure --disable-gui --enable-systemd --with-boost-libdir=/usr/lib/aarch64-linux-gnu CXXFLAGS="-std=c++17"
make -j$(nproc)
sudo make install
sudo useradd -rm qbittorrent -G dietpi -s /usr/sbin/nologin
nano /etc/systemd/system/qbittorrent.service
## add service definition and save file
systemctl daemon-reload
systemctl start qbittorrent
systemctl status qbittorrent
journalctl -u qbittorrent.service

for the service I used following definition

Description=qBittorrent (DietPi)
After=network-online.target dietpi-boot.service



Wow this has blocked the odroid, had to reset it

I am trying again with just installing Mate desktop and qbittorrent, but I faced the problem with the login in qbittorrent webadmin, that the password is not correct, isn’t this fixed as I read on github? I don’t remember what I did to reset the password… :frowning:

P.D: nothing still the same no connection on udp trackers… With just installing qbittorrent and Mate desktop…

P. D. 2.: I was able to do all the steps to update but when I open qbittorrent still shows 4.1.5 version… I didn’t see any error during the update process

I install full qbittorrent not the Web ui included on dietpi and happens the same…

on a fresh compiled installation, password is the qBittorrent default one usually

Ok, found a problem… when Nat acceleration on Asus router is enabled, is when I can’t download from qbittorrent, if I disabled the downloads start.

This affects only to qbittorrent on linux, on windows there is no problem…, so is not a problem of Dietpi

Thank you for your help and time.