qbittorrent login issue

I just realised I presented my problem as an append to a “solved” thread so I am replicating it as a fresh thread

I have latest DietPi on Raspberry Pi 3
and I never could be able to log into qbittorrent

I tried

  • qbittorrent / adminadmin
  • qbittorrent / dietpi
  • qbittorrent / (which I had changed at first boot)
  • deleting the PWD line from the conf file + restarting the service + retrying all the above

No joy. The qittorrent gui won’t let me in.

Help please! :cry:

I nailed the problem

  1. My antivirus was blocking unencrypted password transmission.
  2. qBittorrent GUI is known to have problems with any Chromium-based browser (and I’m using Chrome)

After adding an exception to Bitdefender, and accessing qBittorent web gui from Edge I finally could log in.

That being said in favour of others that might find this note in the future, the question now moves to: change browser or change torrent client?

Probably I should do both, tbh :slight_smile:

Ah great you found that out already (as of other thread). So indeed Chromium based browsers are an issue. I faced the same with Opera, while on Edge it worked well.

Since the qBitTorrent package from Debian Stretch repo has not changed since 2017, and I didn’t face this issue earlier, it must be due to some later Chromium change. I wonder if this has been fixed already with newer qBitTorrent versions… Either we need to install a newer version from a different source (or source build) or we at least need to inform users via our online docs.