PSU noise reduction and now can't connect to display

Sorry I am an absolute noob, I thought I could use the feature in dietpi-config, pick audio, and enable psu noise reduction would be fine, but my hdmi didn’t work. It disabled my hdmi, was there a warning that I did not know? It would be very helpful to put something like “hdmi will be disabled” so people don’t make the same mistake like me.

I had to ssh my device to get hdmi enabled again…


Creating a bug report/issue

Required Information

  • DietPi version | latest
  • Distro version | latest dietpi pi4b
  • Kernel version | kernel 5?
  • SBC model | rpi4 b
  • Power supply used | 15w + usb hub with own supply?
  • SD card used | 16gb

Additional Information (if applicable)

  • Software title | lxde desktop
  • Was the software title installed freshly or updated/migrated? | just turned it on
  • Can this issue be replicated on a fresh installation of DietPi? | yes
  • Bug report ID | echo $G_HW_UUID

Steps to reproduce

  1. …in terminal type “sudo dietpi-config”
  2. …go to audio → go to noise psu and enable

Expected behaviour

  • … warn me hdmi will be disabled?

Actual behaviour

  • … i can’t display anything… my fault

Extra details

  • … it blinks a black blank screen and shuts off

Hi,

welcome to our community. It should be possible to connect to the RPi using SSH. Isn’t it?

BTW: there is a warning :wink: >> Display output = disabled

 ┌──────────────────────────────────────────────────┤ DietPi-Config ├───────────────────────────────────────────────────┐
 │                                                                                                                      │
 │ PSU noise reduction:                                                                                                 │
 │                                                                                                                      │
 │ This mode attempts to reduce power consumption on your SBC. In turn, this may reduce PSU inflicted noise, that may   │
 │ degrade audio output quality.                                                                                        │
 │                                                                                                                      │
 │ The following will now be applied:                                                                                   │
 │  - CPU governor = powersave                                                                                          │
 │  - Display output = disabled                                                                                         │
 │                                                                                                                      │
 │ Do you want to continue?                                                                                             │
 │                                                                                                                      │
 │                                   <Ok>                                       <Cancel>                                │
 │                                                                                                                      │
 └──────────────────────────────────────────────────────────────────────────────────────────────────────────────────────┘

Yes, this is really an option for headless server systems, turning off all hardware features not required on servers and reducing power consumption and current flows on the PCB to reduce analogue audio signal interferrance.