Proxmox problem with reboot and mount

Hello all,

I have 2 problems with proxmox and looking for a solution

  1. a reboot is only possible if I enter poweroff in the terminal. since proxmox only does a shutdown command this is not so great.

  2. when i reboot the node, i have to start dietpi 2x to mount a usb-disk. here i set dietpi to “do not start automatically” and see the usb-disk on the node. now i start dietpi and nothing happens. after the next start of dietpi it suddenly finds the usb-disk and mounts it.
    I entered it in fstab, but why not the first time ?
    mounting with a reboot does not work either.
    only switching off and starting works.

has anyone else had this problem and how did you solve it?
(image is a normal pc x86)

ping @StephanStS and @HolgerTB as both running quite some Proxmox installations.

Let’s start with the reboot issue: I don’t see this, my (many) VMs are booting well with reboot as well as with shutdown -r now.
Can you give us a screenshot of your VMs hardware configuration and options?

I hope that’s what you wanted.
2023-03-07 10-44-30

2023-03-07 10-42-20

2023-03-07 10-42-50

shutdown requires dbus to be installed. Better to use poweroff and reboot commad.

I think that’s my problem.
a reboot with (!) proxmox initiates the command with shutdown.

I am therefore forced to go into the terminal with the command poweroff.

Can you test shutdown -h now?
shutdown alone give the same behaviour like at your screenshot.
shutdown -h now, poweroff, reboot works in my environment.

I guess @murphydoe is going to click within Promox UI on a shutdown button and this is giving the error. Did you tried to install dbus tools?

the commands all work. shutdown alone does not

I’ll do that now…installed

You need to apply this and enable qemu guest in the settings of the vm

systemctl unmask systemd-logind
apt install dbus
systemctl start systemd-logind
apt install qemu-guest-agent

You can refer to this post on my blog:


Perfect. This worked also in my VM test.

@murphydoe: If this also helps for your problem, could you please close this issue?

Yeah great. Works

I know Holger and follow him.
I must have slept through his contribution.

Thanks a lot

1 Like
sudo apt install qemu-guest-agent

make sure you have in the options section that the vm is enabled QEMU guest agent for PROXMOX to be able to issue the reboot command properly, otherwise the VM is completely oblivious to a shutdown/reboot command issued from the PROXMOX server and more or less is just like having the power plug yanked from a bare metal machine

you can also see if qemu-guest-agent is installed by trying

sudo systemctl enable qemu-guest-agent.service
sudo systemctl start qemu-guest-agent.service

you can then pull status to see if it's running.
sudo systemctl status qemu-guest-agent.service

Disregard…just saw HolgerTB post! Great job!