ProFTP, use the root directory?

Hi, I want to set up ProFTP to use “/” as root directory when I log via FTP client. How’s that possible? Tried to set “/” as path directory but it seems not working.

Thank you!




DefaultRoot /

and restart proftpd

service proftpd restart

(i think)

Yeah, when I said:

Tried to set "/" as path directory but it seems not working.

I mean that I just tried with no success. Cannot see the root of my MicroSD.

Did you try setting Proftpd as root user?

Yes, tried.

Got it working with:

DefaultRoot / root
DefaultChdir / root

set in proftpd.conf.

Never liked proftpd, ot it didn’t liked me, but i hope this is what you searched for :slight_smile:

Damn, worked! Thank you very much!

Hi, it seems that I don’t have write permissions. With an FTP client I get 500: Permission denied.

Did you ever resolve this? I just setup dietpi for the first time with ProFTPD.
I am able to connect from my Mac using Filezilla to Pi using user: root and pw: dietpi, but one line states “Insecure server, it does not support FTP over TLS.”

When I try to transfer files to Pi, I get “Response: 550 background.jpg: Permission denied. Error: Critical file transfer error after transferring 262,144 bytes in 1 second”

Any help would be greatly appreciated!

It connects with user:dietpi pw:dietpi. What is that about?