Problems with qBittorrent - Ports? USB stick?

Creating a bug report/issue

Required Information

root@Snowflake:~# sudo cat /boot/dietpi/.version

root@Snowflake:~# sudo echo $G_DISTRO_NAME $G_RASPBIAN
bullseye 1

root@Snowflake:~# sudo uname -a
Linux Snowflake 6.1.21+ #1642 Mon Apr  3 17:19:14 BST 2023 armv6l GNU/Linux

root@Snowflake:~# sudo dpkg --print-architecture

root@Snowflake:~# sudo echo $G_HW_MODEL_NAME
RPi B (armv6l)

DietPi v8.19.1 : 18:55 - Di 18.07.2023
 - Device model : RPi B (armv6l)
 - CPU temp : 58 Β°C / 136 Β°F : Running warm, but safe
 - LAN IP : (eth0)
 - MOTD : DietPi v8.19 has been released. Check out all changes:

root@Snowflake:~# dietpi-services status qbittorrent

 Mode: status qbittorrent

[  OK  ] DietPi-Services | qbittorrent		active (running) since Tue 2023-07-18 18:52:51 CEST; 20min ago

root@Snowflake:~# lsblk -o name,fstype,label,size,ro,type,mountpoint,partuuid,uuid
sda               14,6G  0 disk                                                 
                  14,6G  0 part            0012e150-01                          
sdb               57,6G  0 disk                                                 
     xfs          57,6G  0 part /mnt/64GB  2c61c78e-01                          e8277209-48c2-48d7-8501-e7c075878614
β”‚                 14,7G  0 disk                                                 
β”‚    vfat          128M  0 part /boot      727cff46-01                          463B-CEC5
     ext4         14,6G  0 part /          727cff46-02                          dcbd9214-f41c-4689-bd45-cfb04de2204c
  • SD card used | (EG: 16GB Transcend)

Additional Information (if applicable)

  • Software title
    Snowflake, qBittorrent

Steps to reproduce


unfortunately my downloads/uploads do not start under qBittorennt. I have the same problem with Transmission.

DietPi: 16 GB SD card
Backup: 16GB USB stick
Torrent: 64 GB USB stick

At first I thought it was because of the guest network of the Fritzbox, meaning I can’t open ports for the Raspberry Pi. However, I have no problems with qBittorennt with my laptop and Linux Mint on the same guest network. Download and upload work without problems. So I thought ports would not be a problem.

I mounted my 64GB USB stick with XFS and MBR(also test GPR and ext4). Name of the stick 64GB. Is it possibly due to read/write permissions of the stick? Thanks

yeah, probably a permission issue, the install script does:

G_EXEC usermod -g dietpi -aG debian-transmission debian-transmission

which means, the user debian-transmission (which executes transmission) is added to the group dietpi (and the group debian-transmission), while dietpi becomes the default group for the user,
This is necessary because (by default) transmissions saves to /mnt/dietpi_userdata/downloads, which is owned by dietpi:dietpi and has 775 permissions, so you need to belong to the group to write to it.

So let’s check the permissions of your download location:

ls -la /mnt/64GB/
1 Like
root@Snowflake:~# ls -la /mnt/64GB/

drwxr-xr-x  3 root root   21 18. Jul 18:55 .
drw-r--r-- 10 root root 4096 18. Jul 17:58 ..
drw-r--r--  2 root root    6 18. Jul 18:55 Torrent

The β€œTorrent” folder is not mandatory.
Either simply the 64GB as root or just the folder mnt/64GB/Torrent

all folder or owned by root user and there is no write permission for anyone else… Means root is the only one who is able to write to that folder.

Hello thank you. Can I just take away root as user from the complete USB stick? Does this need to be formatted again extra for this? Or do I have to log in to DietPi with my user?

usually, permissions can be set per file or folder. Can you try following

chmod 777 /mnt/64GB/Torrent
ls -la /mnt/64GB/
root@Snowflake:~# chmod 777 /mnt/64GB/Torrent
root@Snowflake:~# ls -la /mnt/64GB/

drwxr-xr-x  3 root root   21 18. Jul 18:55 .
drw-r--r-- 10 root root 4096 18. Jul 17:58 ..
drwxrwxrwx  2 root root    6 18. Jul 18:55 Torrent

Unfortunately still β€œError”.
With the encryption under qBittorrent it probably has nothing to do?

do you have an error message?

I remember that I had already managed to get the 50GB at the bottom of β€œFree space”. In the meantime, there is also only unknown.

can you try following

chmod +x /mnt/

and share again

ls -la /mnt/64GB/

how does it go now?

1 Like
root@Snowflake:~# chmod +x /mnt/
root@Snowflake:~# ls -la /mnt/64GB/
insgesamt 4
drwxr-xr-x  3 root root   21 18. Jul 18:55 .
drwxr-xr-x 10 root root 4096 18. Jul 17:58 ..
drwxrwxrwx  2 root root    6 18. Jul 18:55 Torrent

Thanks, looks good for now.

Does it make sense to apply this to 64GB/mnt/Torrent only?

Under /mnt/ runs also my 16GB USB stick for backups, correct?
So I ask because the OS SD card is also running a Tor-Snowflake.

Thanks! :slight_smile:

Issue was with /mnt/ directory as due to whatever reason, the execute flag has been removed. This prevents all apps from writing to any of the sub directories. This is possible now.

1 Like