Problems when trying to install spotifyd

Creating a bug report/issue

Required Information

  • DietPi version | 8.3.1

  • Distro version | Buster 1

  • Kernel version | Linux MopidyNest 5.10.103-v7+ #1529 SMP Tue Mar 8 12:21:37 GMT 2022 armv7l GNU/Linux

  • SBC model | RPi 3 Model B (armv7l)

  • Power supply used | 5V 1A dietpi foundation

  • SD card used | SanDisk ultra 16gb

Additional Information (if applicable)

  • Software title | Spotifyd
  • Was the software title installed freshly or updated/migrated? I was trying to install software from dietpi-software
  • Can this issue be replicated on a fresh installation of DietPi? Maybe have not tried
    ← If you sent a “dietpi-bugreport”, please paste the ID here → 3efd035e-f4b6-4f95-98dd-3a6a55ade2d2
  • Bug report ID | 3efd035e-f4b6-4f95-98dd-3a6a55ade2d2

Steps to reproduce

  1. …launch dietpi-software choose to install spotifyd

Expected behaviour

Spotifyd should be installed without errors

Actual behaviour

I got an Error prompt that tells me that FAILED] DietPi-Software | mkdir /mnt/dietpi_userdata/spotifyd/cache

Extra details

Can you try following

mkdir -p /mnt/dietpi_userdata/spotifyd/cache

And rerun the installation

worked as a charm, thank you !