Problem with my External Hard Drive


I am having a problem connecting my External Hard Drive with my installation of DietPi.

I have two installations of DietPi. One on a Raspberry Pi 3 B+ and one on an old Acer Aspire One (Native PC version). I am having the same problem on both of my DietPi installations.

When I plug in my Orico 3.5 Inch External Hard Drive Enclosure with a Western Digital 2TB Hard Disk inside I get the following showing on my screen:

usb 1-1: device descriptor read/64, error -71
usb 1-1: device descriptor read/64, error -71
usb 1-1: device descriptor read/64, error -71
usb 1-1: device descriptor read/64, error -71
usb 1-1: device not accepting address 4, error -71
usb 1-1: device not accepting address 5, error -71
usb usb1-port1: unable to enumerate USB device

if I run DietPi-Drive_Manager my HDD is not shown.

I have tried all combinations of MBR and GPT partition styles, and NTFS and exFat File systems.

I am having no issues on my laptop running windows.

I have put another Hard Drive (Western Digital 120G) into the enclosure and it works fine.

Does anybody have any ideas, please.



looks some issues on the HDD to get detected correctly. But this is not a DietPi issue as DietPi is just trying to get the information from underlying Debian image.

can you connect your HDD again and run following 2 command

lsblk -o name,fstype,label,size,ro,type,mountpoint,partuuid,uuid

This needs to show your HDD. If not, no chance for DietPi to get your HDD connected.

Btw: is you enclosure externally powered? It might be the HDD require some more power to be able to work than the other one?

Thanks for your reply Joulinar.

I have run those two commands with my external HDD plugged in. It is not picking up the external.

root@JALAPENO:~# lsblk -o name,fstype,label,size,ro,type,mountpoint,partuuid,uuid
sda               298.1G  0 disk
     ext4         298.1G  0 part /          0641d005-01                          2e9d8509-a765-48ba-ba71-4110f21ef219

root@JALAPENO:~# blkid
/dev/sda1: UUID="2e9d8509-a765-48ba-ba71-4110f21ef219" TYPE="ext4" PARTUUID="0641d005-01"

Only shows the local disk.

Yes, my external HDD is externally powered (and it is plugged in and powered on). I was also thinking this is some sort power problem, like it needs more.

I guess I will have to try looking around in some Debian forums.

Thanks for your help

that’s bad indeed as it doesn’t seems to be recognized by the Linux sub system. You can have a look to kernel error messages. Maybe it will give some hints why it’s failing.

dmesg -l err,crit,alert,emerg