problem SSL activating for owncloud

Hy i have a problem to activate ssl on my xu4.
I used this
Create key:

Code: Select all
mkdir -p /etc/apache2/ssl
openssl req -x509 -nodes -days 1000 -newkey rsa:2048 -keyout /etc/apache2/ssl/apache.key -out /etc/apache2/ssl/apache.crt

Enable SSL config and restart Apache:

Code: Select all
chmod 600 /etc/apache2/ssl/*
cat << EOF > /etc/apache2/sites-enabled/default-ssl.conf

ServerAdmin webmaster@localhost
DocumentRoot /var/www

LogLevel error
ErrorLog ${APACHE_LOG_DIR}/error.log
#CustomLog ${APACHE_LOG_DIR}/access.log combined

SSLEngine on

I have an account on noip

and a fritzbox 3490. Activating noip there.
But when going on

Then standing url not found.

Plz help me

changed in default-ssl.conf to

so i deactivated https acess on my fritzbox. Now i get access but

Strict Transport security http header is not configured to least 15768000 seconds. For enhanced security we recommend enabling hsts as described

No memory cache has been configured

And Webdav over https is not working. Can someone help me plz

OPcache is enabled for LAMP on Jessie:

Appears Owncloud requires php5-apcu for memcaching:

apt-get install php5-apcu

add the following to /var/www/owncloud/config/config.php :

 'memcache.local' => '\OC\Memcache\APCu',

Restart services:

dietpi-services restart

Memcache is now active.

The “Strict-Transport-Security” HTTP header is not configured to least “15768000” seconds. For enhanced security we recommend enabling HSTS as described in our security tips.

If you require this level of security, follow their documentation:

Have you enabled 443 port forwarding?
What webdav client are you using?

I’ve updated the Owncloud documentation to allow for enabling the memcache: