Problem login new install rpi0w

Hi everyone.
I’m trying to install DietPi on my rpi0w but I can’t log in.
I tried everything I read before writing: tried the default user and password (root - dietpi) but nothing. I tried setting a different username and password in the dietpi.txt file but nothing.
I turn on the Raspberry and when the login screen comes I can’t go on anymore.
I downloaded the image from the site so I think it’s right… I couldn’t try other versions because I couldn’t find them.
Can someone help me?
Thank you.

You need to login as user root first time to complete initial setup. Ensure the password fits to the one specified in /boot/dietpi.txt


Already done. Nothing.
The default password written in the file is correct (dietpi).
It was the first test I did leaving everything unchanged: user: root password: dietpi.
The message with written incorrect login always appears

The image file I preloaded is this:
One thing I was noticing but I don’t know if it’s right or wrong, I was using hassos before and the images for my raspberry were ARMhf…
Is there something in it?

ARMv6 is the correct image for RPi Zero W

@StephanStS @HolgerTB @MichaIng Can you try a test install. I don’t have a ZeroW available to test.

I’d love that. But you have to explain to me what you mean by “test install”.

it was not meant for you, I ask 3 team mates for assistance

:joy: sorry… I misunderstood… I just love testing and helping to solve problems.

I made a test installation. All works as expected.

Maybe you try another ssh client. In windows just type ssh root@ip-address-of-your-pi and diet as password.

Otherwise try to use putty as ssh client

I connected the Raspberry directly to the monitor and keyboard. I’m trying to log in directly.

can you try to connect via SSH? Or use a different keyboard?

So… In the DietPi.txt file I set:


While in the dietpi-wifi file I entered:


But nothing connects. So I can’t use SSH yet.

Right now I don’t have another keyboard… I could try to get one, but it has always worked for years and years.
Even with the Hassos I used it directly from the Cli.

did you put the wifi name and passkey in ’ '?


Other parts of the file:


Otherwise I haven’t changed anything.

I tried to spell it like ‘Manu’s_family_2.4G’ was the first thing I did… and then I tried “Manu’s_family_2.4G” and finally I tried nothing like this Manu’s_family_2.4G

Which of the 3 is correct?

Same for the passkey

Like it is in the original file. With ’ ’

you have two problems here:

  1. dietpi-wifi.txt is only used at the first boot. If you change it after the first boot is has no more effect!
  2. The actual problem is that in your Wifi name (SSID) is an ’ ! this will not work, the SSID name will not be parsed correctly

Ok, for the 1 problem and everything is ok. I was aware that it was only scanned on first boot, in fact every time I rewrote the image on the SD card.
As for the second problem, I was afraid that ’ might have bothered me… tomorrow I’ll change the network name and try again.
Do you think that an access from SSH instead of Raspberry itself can change?

Is there anything else in the file that I need to change or haven’t changed?

yes. and just enter in the dietpi.txt the change of the active lan connection (wifi) and leave the rest (locales etc.) unchanged.

In dietpi-wifi.txt just enter your (new) SSID and passkey. any you will be good to go.

locales and the rest of the settings you can change in dietpi-config after the base installation.

good luck

Thank you. I’ll try tomorrow and let you know.

About the ' character: It should work, but it needs to be escaped as described in the comment above the SSID line in dietpi-wifi.txt, which assumes also the surrounding ' to stay:

# - Please replace single quote characters ' in your key with '\''. No other escaping is required.

So in your case: