Problem installing USBridge as Roon Endpoint

Got the USBridge and Sparky SBC today. Came with Dietpi software. I went to the Dietpi website and downloaded the dietpi.txt for Roon Endpoint. Connected DAC (Dragonfly Red) to the USbridge, Ethernet cable and power to the Sparky Board. Power LEDs come on. Red light on the Sparky board flashes on and off but nothing happens. With eMMC connected, I get power to the DAC but Ethernet doesn’t come on. With microSD card connected, eMMC disconnected, Ethernet comes on but there is no power to the DAC. . I’m powering the unit with a iFi ipower 5vDc, which should be adequate power.

I hope someone from is reading this topic and will respond.


Thanks for the report.

This has all the indicators of a insufficient power supply issue. Although, I’am not 100% sure on the PSU requirements for USB bridge + sparky, however, Allo provide 5v/3A PSU’s, yours is currently 5v/2.5A.

The other issue may be a bad image write of DietPi.

First, lets first try a fresh image write of DietPi to eMMc:

  • Download the Sparky DietPi image and write to eMMC:
  • Download the Roon automation template and save to /boot/dietpi.txt : (ADMIN EDIT: Removed outdated link)
  • Make sure USB bridge is attached and USB DAC
  • Power on device with eMMC attached.

If problems occur, lets check if reduced power load may be a factor:

  • Do the same process of image write as above
  • Unplug the USB bridge (and USB DAC)
  • Power on device with eMMC attached.

I’ll also update our DietPi image to latest version, as this contains a kernel update which may be required for USB bridge. I’ll post here later today when its ready, you may wish to hold off testing until then.

Image updated to latest (including updated dtb overlay). Please continue with the section highlighted in Green:

As you suggested, I installed v152 of Dietpi and the Roon Automation Template. Connected Ethernet, DAC and power. The power LEDs on both Sparky and USBridge came on, as did the DAC attached to USBridge. However, no Ethernet connection. The red LED on the Sparky board flashed on and off at two-second intervals—the indicator lights on my Ethernet switch also flashed on and off at the same time. That just went on and on. So, I took the next suggested step. Unplugged everytihing, I disconnected USBridge and DAC. Powered up Sparky with Ethernet connected. Same result.

I have used Dietpi with the HifiBerry Digi+ and Digi+ Pro, so have some experience with the software. I know it to be absolutely reliable. I believe at this stage it isn’t a software or power supply issue. It must be a defective Sparky SBC. I’ve been in contact with They’re very chaotic in their communication, and have wasted a lot of my time. They don’t seem particularly keen to replace the defective item. I’ll try once again and after that escalate via Paypal.

Hi Hrothgar,

Sorry to hear your having a bad experience with your Sparky SBC + USB bridge purchase.

Allo are sending me a USB bridge, this will allow me to run tests our end. If we can replicate the same issues, I’ll work with Allo to get this resolved. If not, could confirm a possible defect with your board and/or setup.

Allo may have already checked this with you, however, are you powering the USB bridge through its barrel DC jack, or, Sparky SBC micro USB? I believe (as per the Kali), USB bridge barrel jack may be required only, and, will power both units.

There may also be a large power draw from the unit during initial boot, exceeding available 2.5A (we see this with Odroid Xu4, 4A+ during boot). Although once my unit arrives, i’ll be able to run some power tests.

I’d be interested in your experience with Sparky SBC and USBridge. I tried both the barrel jack and micro USB. One has to remove the shorting plug when powering the unit through the USBridge. Anyway, the power LEDs on both units lit up and so did the DAC when connected to Sparky. However, even with the latest version of DietPi (v152), ethernet connection couldn’t be established. Fundamentally, the unit wasn’t booting up, I believe. Any number of things could be wrong. Maybe the card drives are corrupted. Perhaps, ethernet was not wired properly, etc. What stumped me was why they wouldn’t send a replacement Sparky for me to try. I gave them the option to replace or refund. Since they wouldn’t replace I had to go for a refund. This is a fast-moving market and one would think that fledgling companies like would want to consolidate their position by offering great customer service in addition to a good product.

Have you had a chance to test’s USBridge yet? I was wondering about the PSU requirements: I tried it with a 5v 2.5a switching power supply from iFi Audio. Didn’t work even with Sparky SBC alone. I’ve returned the items. However, I was wondering, quite apart from the possibility that it might require 3 amps to power up, whether with the USBridge attached it’ll need a slightly voltage as well. I know MicroRendu, which seems to operate on the same principle though everything is integrated on to one board, needs between 6-9 volts DC, 7.5 v being the optimum. Please let me know how your testing goes. I’m very much in the market for just such a unit.


Had an issue with one of the Sparky boards, would result in USB 1.0 output only on USB bridge, the guys at Allo are looking into this. The other Sparky board runs USB bridge fine.

The issue with loss of ethernet has been resolved in our latest image update, that issue was on us:

In all tests, I used the provided Allo 5V/3A barrel PSU adapter, powering the USB bridge directly.
Allo confirms the microUSB connector can only provide around 1.5A to the board. So I believe the 5V/3A barrel PSU adapter would be required to run USB bridge, to ensure sufficient power.

The Sparky and USB bridge are 5V input only. 6V or higher would damage the board.

Are Allo going to replace the item, or have you been offered a full refund? Either way its a shame, the Sparky + USB bridge combo is a real audio treat once its up and running :slight_smile:

Good to know the USBridge is working. Could have been a power supply + software issue, though I had 2.5a on the iFi 5 volt DC power supply. In all the email I had back and forth with them, it never struck the people at Allo to suggest it was an inadequate power issue. I was an early adopter. Without troubleshooting skills, I had to return the unit for a full refund. I’m going to wait for the product to mature a bit, and gauge the reactions of various users. In the meantime, I’m using the USB on my Windows 10 laptop with Fidelizer 7.8 and Jplay 6.2. Sounds good through my Modi Multibit DAC and a solid-state headphone amp I got from China! I like the simplicity of DietPi and so will definitely be back once I have a good idea of what non-technical people like me are doing with USBridge.