Problem after upgrade HA 3.6.1 with 8.18 ha-av library

Creating a bug report/issue

Required Information

  • DietPi version | 8.18.2
  • Distro version | bullseye 1
  • Kernel version | Linux 6.1.21-v7+ #1642 SMP Mon Apr 3 17:20:52 BST 2023 armv7l GNU/Linux
  • Architecture | armhf
  • SBC model | `RPi 3 Model B+ (armv7l)

During install upgrade HA , the Ha-av not upgrade for this error

pv -O2 -fPIC -I/usr/include/arm-linux-gnueabihf -I/usr/include/python3.9 -c src/av/sidedata/sidedata.c -o build/temp.linux-armv7l-cpython-39/src/av/sidedata/sidedata.o
      src/av/sidedata/sidedata.c: In function ‘__pyx_pymod_exec_sidedata’:
      src/av/sidedata/sidedata.c:5662:9: error: ‘AV_FRAME_DATA_SEI_UNREGISTERED’ undeclared (first use in this function)
       5662 |   if (((AV_FRAME_DATA_SEI_UNREGISTERED != -1L) != 0)) {
            |         ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      src/av/sidedata/sidedata.c:5662:9: note: each undeclared identifier is reported only once for each function it appears in
      error: command '/usr/bin/arm-linux-gnueabihf-gcc' failed with exit code 1
      [end of output]
  note: This error originates from a subprocess, and is likely not a problem with pip.
  ERROR: Failed building wheel for ha-av
Failed to build ha-av
ERROR: Could not build wheels for ha-av, which is required to install pyproject.toml-based projects
homeassistant@sdomotica:/root$ dpkg --print-architecture

maybe you can have a look into similar report Cannot install ha-av after upgrading to Python 3.10.9

Sorry help , I try to compile new version of ffmpeg but now

I have this error
Building PyAV against static FFmpeg libraries is not supported.

Now I don’t know what to do. Even reinstalling FFmpeg doesn’t change

any idea to clean the library ?

can you check this post?

I try It but there are some library in static mode that I don’t find for remove

I’m facing the same error after upgrading to Bookworm on my Rpi. Cannot build ha-av.
On the HA community they say that ffmpeg has to be rebuild and configured with these options:

./configure \
    --extra-cflags="-I/usr/local/include" \
    --extra-ldflags="-L/usr/local/lib" \
    --extra-libs="-lpthread -lm -latomic" \
    --arch=armel \
    --enable-gmp \
    --enable-gpl \
    --enable-libass \
    --enable-libdrm \
    --enable-libfreetype \
    --enable-libmp3lame \
    --enable-libopencore-amrnb \
    --enable-libopencore-amrwb \
    --enable-libopus \
    --enable-librtmp \
    --enable-libsnappy \
    --enable-libsoxr \
    --enable-libssh \
    --enable-libvorbis \
    --enable-libwebp \
    --enable-libx264 \
    --enable-libx265 \
    --enable-libxml2 \
    --enable-mmal \
    --enable-nonfree \
    --enable-version3 \
    --target-os=linux \
    --enable-pthreads \
    --enable-openssl \
    --enable-hardcoded-tables \
    --enable-pic \
    --disable-static \

How can I do that on DietPi v 8.19.1?

I guess this means to compile ffmpeg yourself on your system CompilationGuide/Ubuntu – FFmpeg

thx, this worked.

1 Like