Possible to upgrade kernel to mainline Linux 5.4?

I know Armbian has kernel 5.4 currently and there are some bugfixes in kernel 4.1+ for the Odroid C2 (large Ethernet transfers will crash over scp and whatnot). I also know I can just install armbian for the kernel and swap the rootfs with Dietpi’s rootfs.

The question is, does dietpi have a supported way of upgrading the kernel to mainline?


DietPi did not have an own kernel. It’s using the available kernel from the respective Debian destros.

From all I know, the mainline kernel skips a lot of issues and limits the hardware features compared to the official kernel maintained by hardkernel. As long as their kernel supports the latest Debian version, DietPi will official stick with it, respectively the kernel/firmware repository from Meveric.

Just read through the Armbian forum for Odroid devices and you’ll see lots of issues + loose supports for Meveric Xserver + Kodi etc packages with GPU acceleration.

But of course you can just use the Armbian image and use our preparation script to turn it into DietPi. Select genetic device 22 when asked, since choosing the Odroid expects it to be a Meveric-repo image.

I see. I wanted to upgrade the kernel to fix the ssh issue. Is there any manual way to fix ssh over Ethernet as outlined in these two posts?



These fixes do not refer to the official kernel provided by hardkernel AFAIK, also I never heard about Ethernet issues there.

Could you describe more detailed what issues you face? Does dmesg or journalctl show any hints when your connection fails?

So I found out that if you do file transfers over scp, it will oftentimes fail/not complete. I have also tried rsync with the same result. Using git clone on an ssh repo will have it go almost to 100%, or it will reach 100% and it will fail to checkout. However, if you run it multiple times, sometimes it will be successful. I found that the fix was to upgrade the Linux kernel past 4.1 or so (I used armbian 5.4) and it will work 100% of the time.

I originally encountered the issue using Hardkernel’s latest Ubuntu. I didn’t check those two things, I had moved on from that because I thought upgrading the kernel fixes everything but you said there were a ton of issues.

I realize this use case/issue doesn’t affect most users, my job is just trying to use the odroid c2 as an arm testing environment for development.