Plex Update

Unable to update Plex to the newest Version I am a Plex Pass subscriber and it looks like the newest version on the dietpi is the public version.

plexmediaserver-installer is already the newest version (
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

How can I update Plex to Version

The most current public version is As Plex pass user AFAIK you can only upgrade via Plex web UI. Also I guess 1.15.3 is a pre-release version so you need to enable those somewhere as well?

1.15.3 is the Plex Pass version, it’s the “beta/early access to new features” version.

I could manually download the latest version but I really prefer to use apt-get update everything.

Plex does not officially provide an APT repo yet although it is planned. For ARM devices there is currently a 3rd party repo available that was even necessary since Plex did not offer official ARM packages. But now with v1.15 ARM packages have been added and the maintainer of the 3rd party repo (dev2day) already announced that the repo will be shut down in some weeks.

As said Plex plans an own repo then but since this would be available publicly most likely no Plax Pass versions will be shipped there. So if there is no internal updater available you would still need to download them manually.

We currently ship the official packages with fresh installs and will switch to the official repo once available but for Plex Pass versions I see no way that we can automate this currently.

PMS v1.15.3 is in the public update channel now, I have installed it on my desktop already (I am not a Plex Pass owner). How I proceed with installing it on my DietPi box? Just downloading the package manually and using dpkg command to install it? What is the best strategy for uninstalling previous version, the one packaged by dev2day? I do not want to lose my Plex database in the process.

I actually found the instructions on the dev2day, followed them to install public PMS ARM7 binary and it worked without any problems. So I now have v1.15.3.876 running on my Sparky board.

Can you share how you updated it? Im bit new in linux :frowning: trying to update PMS because iOS device cant play files from web client. And on new WebClient this bug is fixed, but when I open from other device my plex webclient I get old version…

Hi scorpio1991,

Here is the instructions quoted:


Finally, official ARMv7 and ARMv8 Plex packages are available:

The repo on has nearly reached its end of life. Please
upgrade to the official packages as soon as possible. This repository
will disappear sometime in the future.

The migration is simple and your Plex library will be preserved.

First, remove the package:
sudo apt-get remove plexmediaserver-installer

Then, remove the repo, e.g. with:
sudo rm /etc/apt/sources.list.d/pms.list

Now, download the appropriate package from and put it on your device, e.g.:

Finally, install the package, e.g.:
sudo dpkg -i plexmediaserver_1.15.2.793-782228f99_armhf.deb

Also, an official Plex repository should be available soon. Most likely, the repo will still NOT work when you read this message!

The following thread has more information:


Small correction:

I believe the actual name of the (old) repository source file you will need to remove is “/etc/apt/sources.list.d/plex.list” and NOT “/etc/apt/sources.list.d/pms.list”, as the example suggests. Other than that, the instructions worked fine for me.

thanks, looks like it worked :slight_smile:

With v6.23 we migrate all installs to the new official APT repo, so from then on you don’t need to take care manual updates anymore but simply run: G_AGUP && G_AGUG