Plex media server web interface not working..

Hi there guys… I have been using dietpi for few weeks now and without any trouble… I have been using plex via kodi addon plexmbc and it was working just fine… but now that there was an official support for plex I wanted to try it… After I installed it and rebooted I am not able to open the web interface… I can see the plex icon in the browser tab bat thats it… I am getting this Error:
This site can’t be reached

192.168.1.112 refused to connect.

What am I missing? :thinking:

Hi mefistos,

Thanks for the report.
Which device are you running (eg: Odroid C2, RPi 2)? I’ll see if I can replicate at my end.

Hi Fourdee,

its on RPi 2…

Thanks,

Works fine my end. Silly question, did you add the :32400/web to the url address, as per the documentation?
http://192.168.1.112:32400/web

I sure did:D I also had plexmediaserver already installed but from different source… as now when I am manually typing the http://192.168.1.112:32400/web address it gives me :
http://192.168.1.112:32400/web/index.html#
http://192.168.1.112:32400/web/index.html#!/status
options… So the question is if it remembers the previous settings and if it does… why cant I access the web interface again… I wonder If I should do apt-get --purge remove plexmediaserver and try again…

Yep, if it was a .deb install, purge should do it. Don’t need to use “remove” with purge:

apt-get purge plexmediaserver

Then reinstall.

still not working… i am lost… is there anything else I could try?

Can you link the guide you followed to install Plexmediaserver previously? There might be something we can find.

Also, please can you send a bug report?
This will send me your system settings which might put us on the right track. No need to fill out the document, simply paste the reference CODE in your reply.

dietpi-bugreport

I believe this is the guide I was using to get the plex server working before :http://www.htpcguides.com/install-plex-media-server-on-raspberry-pi-2/

and this is the reference code: dbaa9a99-484e-46a3-8894-8e5c3a4fa94b-0

Thanks,

These need removing before installing from dietpi-software:

rm /etc/apt/preferences.d/jessie.pref
rm /etc/apt/sources.list.d/pms.list
apt-get clean
apt-get update

Uninstall plex from dietpi:

dietpi-uninstall

Reinstall plex:

dietpi-software

Whats your locale?

locale

The first code:

rm /etc/apt/preferences.d/jessie.pref

gave me no folder or file

my locale is:

LANG=en_US.UTF-8
LANGUAGE=
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

and its still not working :confused:

Very strange, i’ll go through the bug report (system settings) and see if I can find anything.

Great thank you. :wink: … Is there any way how to save all the settings for installed apps and then just restore them without too much hassle? I can just format the SD card and do reinstall, which would be probably faster and less painful for both of us, since its working just fine for you…

Not at the moment, you would need to go through each program manually and copy their configurations. However, if you have not strayed away from what DietPi sets up for you automatically (eg: you haven’t modified the config files), a reinstall might be the best thing.

So, from a clean install:

  • Write image to a different SD card, or backup your current one.
  • As your using USB drive, say “yes” to set it up, but say “no” to formatting. All your previous data will still be there.
  • Install the software you need and plex.

I’d also be willing to debug your current installation over remote desktop (eg: vnc) if you are willing. You’d be able to see everything I do on screen. Let me know if this interests you and i’ll send you the instructions.

Well I believe the USB drive I had in there is not plugged anymore… I am not sure how much does it change anything since everything is working just fine, except the plexmediaserver:D So I might as well do a fresh installation to make everything fresh…

If you want to try debug it via VNC then sure I dont mind… :slight_smile:

That would be ideal, hopefully find out whats causing this issue :slight_smile:

If your comfortable installing VNC server on a windows PC:

  • Download.
  • Install, configure a password for the vnc server.
  • Forward the port for vnc on your router. Think its 5900.

If not, we could try Google’s remote desktop in Chrome:
https://chrome.google.com/webstore/detail/chrome-remote-desktop/gbchcmhmhahfdphkhkmpfmihenigjmpp?hl=en

Heres my skype:
daniel_haze@hotmail.com

I should available later today, but i’ll contact you in Skype to arrange.

oh right… here I thought I will just give you my IP and password for the VNC thats running on the Rpi already… I wouldnt even have to be present since I wont be available until cca 16:15 GMT

EDIT: nevermind I am home… :slight_smile: