[Plex] File is read-only

Just installed Plex on a Pi4, and with dietpi-drive_manager added the movies to /mnt/dietpi_userdate. This is neatly filled (@volume1/Movies) and such. However, the libraries are not filled. Checked some logfiles and noticed there was a problem with creating a grab file. So, I checked, and found out that /mnt is readonly. I can’t change it with chmod-ding it. Must be something I overlook, but no clue as to what.


be default /mnt directly is writable for root user only. Better to create a sub directory inside /mnt and assign appropriate authorization for your application user. usually it should be enough to give write permission for dietpi user group

Okay, I thought to keep it like it was in the instructions

I now have /mnt/Media and gave that folder (at least I think I did) chown to dietpi/dietpi (in midnight Commander)

what instructions you are referring to?

Maybe not really instructions per se, but

Please follow the onscreen instructions to complete the setup wizard:

Create your Plex account by signing up.
Give your server a name (e.g.: DietPi-Plex)
Click library to setup your media locations:

You can also mount Samba/NFS shares by running dietpi-drive_manager and selecting Mount network drive from the menu.

ok but you tried to write directly to /mnt/ and not /mnt/dietpi_userdata/Video or /mnt/dietpi_userdata/Music

Treid that as well, but still those fiolders are empty.

to be honest, I’m lost now. Dietpi has helped me often to make things easier, but this time, I really don’t know.

any error message if you try to write something /mnt/dietpi_userdata/?

Yes, I get

[ Error writing test.txt: Read-only file system ]
(Tried to write nano test.txt)

However, when I go to /mnt/dietpi_userdata/volume1/Movies, I can do write a text file.

to which directory you tried to write the test file? And do you write the file out of an application?

Tried directory /mnt and used nano editor, that failed.

tried direcotry /mnt/dietpi_userdata/volume1/Movies also with nano, and that worked.

I guess you used user dietpi? This is correct that this user can’t write to /mnt directly as it is not allowed by file system permission. By default root user is allowed only to write directly into /mnt

Yes, was indeed using user dietpi.

still I’m confused what your issue is now and what you are trying to achieve

What I’m trying is to add the libraries to Plex. they are stored on my nas ( and I want to be able to watch them on plex. The path on my Synology is /volume1/Movies; /volume1/Series

In /mnt/dietpi_userdata/volume1/ the files are actually visible when logged in as user root, but I still can’t add them to the Plex media server.

What is the error message in Plex and can you share

ls -la /mnt/dietpi_userdata/volume1/