PiZero v1.2 Headless install

Hi,

I’m having issue to install DietPi on a PiZero v1.2 in “headless” mode (i mean without screen).
I followed all the instructions here https://dietpi.com/forum/t/getting-started-download-dietpi-image/24/1 but at Step 4 when trying to connect through SSH it can’t find hostname “DietPi”.

I first tried with Wifi. No success my network doesn’t even see it.
I tried directly with ethernet adapter, no more success.
And of course i also tried usb direct connect to my laptop (i tried on both Linux and Windows)

Any idea of what mistakes i’m doing or step i’m missing ?

Thanks a lot for any help.

Regards,

Hi,

please have a look at: DietPi-Automation

… and edit /boot/dietpi.txt with a linux compatible text editor (e.g. Notepad2) to use a static ip address,
before first boot up
after writing image to sd card!

Hi,

Thx a lot for your answer who helped me to solve my install issue !

I just have one problem left now.

When i’m running apt-get update or upgrade it’s failing.

I have to log into my router at home…then pull the DHCP address from clients to find dietpi

Also…make 100% sure the powersupply can run the Pi…biggest problem I have had to deal with is even though it looks like it up and running, the power from some of my phone bricks would NOT run without crashing the processor.

I guess you could run nmap on a linux device and look for live hosts
sudo nmap -sP 192.168.2.1/24 (change to your LAN network scheme)

yaps is one I just found for windows (they have a port of nmap to windows)

Can you ping www.google.com or any other url?
Might be you need to ensure (if using static IP) that /etc/network/interfaces has a default gateway and dns set to your home router

Please put in here the output of:

cat /etc/network/interfaces



Please put in here the output of:

CODE: SELECT ALL
cat /etc/network/interfaces

Yep, looks like DNS issue.

sorry for the delay i was out for a while.

Well my dns-nameserver is 8.8.8.8 so i guess …it’s not good …

How can i change from static to dynamic ip address ?

I feel so stupid… dietpi-config of course …
I succeed !

nameserver 8.8.8.8

is the google dns server…one of em the other is 4.4.4.4

Those should work…do you have a gateway set for your network hardware

also make sure you set the thread title to [Solved]

For now it’s working i was able to run apt, install soft.
I can also access it ssh.

I just need to validate i can access it from outside.
My next step :slight_smile:

Hmmm

So i succeed to get out from my Raspberry.
Can connect to internet, to run apt and all

But it’s strange my internet box (in France we have all included box playing the role of router, firewall etc) don’t list my raspberry on the connected devices.

And from outside i can’t access it too.