pivpn odroidn2+

If i run pivpn on an odroid n2 plus i get this error? can anybody help?

curl -L https://install.pivpn.io | bash
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 162 100 162 0 0 346 0 --:–:-- --:–:-- --:–:-- 346
100 83358 100 83358 0 0 14492 0 0:00:05 0:00:05 --:–:-- 19790
::: You are root.
::: Hostname length OK
::: Verifying free disk space…
::: Package Cache update is needed, running apt-get update -y …
::: Checking apt-get for upgraded packages… done!
::: Your system is up to date! Continuing with PiVPN installation…
::: Checking for git… already installed!
::: Checking for tar… already installed!
::: Checking for wget… already installed!
::: Checking for curl… already installed!
::: Checking for grep… already installed!
::: Checking for dnsutils… already installed!
::: Checking for whiptail… already installed!
::: Checking for net-tools… already installed!
::: Checking for bsdmainutils… already installed!
::: Checking for iptables-persistent… already installed!
::: Using interface: eth0
::: Using User: dietpi
::: Checking for existing base files…
::: Checking /usr/local/src/pivpn is a repo… OK!
::: Updating repo in /usr/local/src/pivpn… done!
::: Using VPN: OpenVPN
::: Installing OpenVPN from Debian package…
::: Checking for openvpn… not installed!
::: Checking for grepcidr… already installed!
::: Checking for expect… already installed!
::: Failed to install openvpn!
Reading package lists…
Building dependency tree…
Reading state information…
openvpn is already the newest version (2.4.7-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up openvpn (2.4.7-1) …
Can’t locate object method “new” via package “Text::Iconv” (perhaps you forgot to load “Text::Iconv”?) at /usr/share/perl5/Debconf/Encoding.pm line 65.
dpkg: error processing package openvpn (–configure):
installed openvpn package post-installation script subprocess returned error exit status 29
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)


can you have a look how it behave installing OpenVPN directly apt install openvpn

that worked, but i like the pivpn add user to easy adds a user

pls run dietpi-software install 117 now

running it now

same error

│ Setting up openvpn (2.4.7-1) …^M
│ Can’t locate object method “new” via package “Text::Iconv” (perhaps you
│ forgot to load “Text::Iconv”?) at /usr/share/perl5/Debconf/Encoding.pm line
│ 65.^M
│ dpkg: error processing package openvpn (–configure):^M
│ installed openvpn package post-installation script subprocess returned
│ error exit status 29^M
│ Setting up tcl-expect:arm64 (5.45.4-2) …^M
│ Setting up expect (5.45.4-2) …^M
│ Processing triggers for systemd (241-7~deb10u6) …^M
│ Processing triggers for libc-bin (2.28-10) …^M
│ Errors were encountered while processing:^M
│ openvpn^M
│ E: Sub-process /usr/bin/dpkg returned an error code (1)

root@DietPi:~# pivpn add
-bash: pivpn: command not found

it doesn’t make sense to run the PiVPN tool if installation did not complete. :wink:

Maybe an issue with PiVPN. I recall they had some iusses on 64bit bit I’m not 100 sure. Will run a test installation on my RPi4B 64bit test system

i run it on my raspberry pi 4 b yesterday and it worked… no problems at all so its got something to do with odoid?

thnx for your help

indeed the PiPVPN installer seems to have an issue to install OpenVPN correctly. as the installer is not done by us, it’s quite challenging to work around.

Anyway I was able to complete the setup. As soon as I get hit by the error, the error handle screen showed up. On the bottom of the info box, you have a small menu with a couple of options. I selected to open a sub shell. This will keep me inside the installation process but I get a new CLI to get OpenVPN fixed. I was running apt install --reinstall openvpn inside the sub shell. Once installation of OpenVPN succeed, I exit the sub shell and re-run the failed PiVPN installation from the error screen. At lest in my case, PiVPN installer detected OpenVPN now and continue the setup.

did you installed 32bit or 64bit on your RPi4B?

that almost worked for me:

the apt install --reinstall did not find any install on my system
i used apt install openvpn
git clone https://github.com/pivpn/pivpn.git
bash pivpn/auto_install/install.sh

now it works!

thanks for your help

ok you installed PiVPN outside dietpi-software now. But should work same way now

Since updating to v6.43.3 I’ve had constant issues. Firstly using eMMC downloading from Dietpi gives image of v6.28 which works fine. It then updates to latest and fails to reboot.

So I’ve had to use SD card, which boots - slowly - and isn’t stable.

I’ve tried reinstalling both PiVPN and WireGuard in and out of dietpi-software and it is impossible to open.

I’ve never had such issues with Dietpi before. I’ve spend hours trying different solutions but no change… there must be a fundamental issue.