PiVPN no Wireguard option

i tried to install PiVPN in dietpi-software on my Odroid HC1(XU4) with the latest DietPi image. Regarding several tutorials there should appear a window with the option to choose wireguard after choosing the VPN user. This does not happen and it directly install OpenVPN. Is it a bug?



many thanks for your report. Usually this should not be the case and PiVPN should ask if you like to install WireGuard or OpenVPN. Do you see from which source PiVPN is installed? Do you use Debian Buster or Stretch?

I retried with a freshly flashed image. I am using Buster which is the default. I just changed network settings to static IP. After that i start the installation of PiVPN. I get this error:
::: Your system is up to date! Continuing with PiVPN installation…
::: Checking for git… already installed!
::: Checking for tar… already installed!
::: Checking for wget… already installed!
::: Checking for curl… already installed!
::: Checking for grep… already installed!
::: Checking for dnsutils… already installed!
::: Checking for whiptail… already installed!
::: Checking for net-tools… already installed!
::: Checking for bsdmainutils… already installed!
::: Checking for iptables-persistent… not installed!
::: Failed to install iptables-persistent!

I have no idea why the installation of iptables-persistent fails. After a reboot i tried it again and it runs through till the configuration option window. But still no wireguard option.

Edit: PiVPN is cloned from https://github.com/pivpn/pivpn.git


could be that WireGuard is not supported on your device? I tested installation of PiVPN on my VM and it display WireGuard. :thinking:

As the installation script is downloaded from PiVPN side, maybe better to check directly with them. Probably they know why the installer is not offering WireGuard. https://github.com/pivpn/pivpn

Yeah i think i found the lines (from 1113) in the install script. If OS is NOT Raspbian or CPU architecture is NOT X86 then it automatically sets VPN to OpenVPN.

elif [ "$X86_SYSTEM" -eq 0 ]; then
	echo "::: Using VPN: OpenVPN"

I installed the plain wireguard now without PiVPN and it works great :smiley:

Yep indeed, but this is a behaviour of the PiVPN script themselves, outside DietPi area. Personally I’m using native WireGuard as well, as I don’t feel the need of having the overhead of an admin Gui like PiVPN :wink: