PiHole Web Interface is not working


After installing PiHole, web interface has worked.
But after restarting DietPi, wenn i want to open PiHole I’m getting follower error: 500 Internal Server Error

Why and how can I fix it?


which web server you are using?

I’m using Lighttpd
But now I can’t connect over SSH :frowning: - host is unreachable.

do you have a screen you can connect?

I have three times rebooted my rp3 and now is working (PiHole).
But probably something with my PiHole setting is wrong.

Blocked queries and procent is 0.

do you see Blocked entries in your Query Log?

No, in Query Log I don’t have any Blocked entries.

but you see queries in general? Did you tried to open a web page with some ads on it? does it get blocked?

Yes, in general I see the queries.

But very often: OK
(forwarded to localhost#5335)

I’m opening the web without ads and noting is blocked.

Means technically ads are blocked by this is not displayed on web UI? Correct?

I see on my router B818 that DietPi online ist. But again, no connection over SSH and Webinterface (DietPi and PiHole) :frowning:

I mean that the ads are not blocked and not displayed
(Sorry, earlier I expressed myself wrong).

Looks like your system has some more issue. Can you connect a screen and reboot? Does it boot correctly?

I disconnected the plug from the electricity and plugged in.

Now the queries are blocked and Webinterface is working.

How can I check that does it boot correctly?
Do you need some logs?

I guess it booted correctly now. However you could have a look to kernel messages if there are errors

dmesg -l err,crit,alert,emerg

I have pasted your command to SSH console, but it didn’t display anything.

this means there are no error messages present, which is good.

If I have this error 500 Internal Server Error
The same error I have on either on PiHole and DietPi web interface :frowning:
I have no idea why sometimes I working and sometimes have this error.

I rebooted one time every day(plug out and plug in power cable).

this looks like issues with the SD card. Best would be to connect monitor and keyboard to be able to check what happen. Another option is to enable full log mode using dietpi-software. Maybe there is something in the logs that could give an indication after reboot.

Is unbound service running?
Also you need to point your DHCP server to assign IP’s out pointing to your PiHole IP address…right now all the clients are not looking to PiHole for DNS resolution

Yes unbound is also running.

Yesterday I have updated DietPi to 7.2, and today I have the same error “500 Internal Server Error”.

I think on the base version (7.1?) I didn’t have this problems.

Maybe this is the issue?


What setting should I change to avoid this problem?