pihole-FTL.service not removed on uninstall

Creating a bug report/issue

Required Information

  • DietPi version | cat /boot/dietpi/.version
    G_LIVE_PATCH_STATUS[0]=‘not applicable’
  • Distro version | echo $G_DISTRO_NAME $G_RASPBIAN
    bullseye 1
  • Kernel version | uname -a
  • SBC model | echo $G_HW_MODEL_NAME or (EG: RPi3)
    Linux rpi1 5.15.84+ #1613 Thu Jan 5 11:58:09 GMT 2023 armv6l GNU/Linux
  • Power supply used | (EG: 5V 1A RAVpower)
    Generic 5V 1.2A
  • SD card used | (EG: SanDisk ultra)
    SanDisk Extreme Pro 8GB

Additional Information (if applicable)

  • Software title | (EG: Nextcloud)
  • Was the software title installed freshly or updated/migrated?
  • Can this issue be replicated on a fresh installation of DietPi?
    ← If you sent a “dietpi-bugreport”, please paste the ID here →
  • Bug report ID | echo $G_HW_UUID

Steps to reproduce

  1. Install pihole-FTL and unbound using dietpi-software
  2. Uinstall pihole-FTL using dietpi-software (keeping unbound to use for AdGuardHome)

Expected behaviour

  • pihole-FTL.service (/etc/systemd/system/pihole-FTL.service) should be removed so that it doesn’t show up in dietpi-services anymore

Actual behaviour

  • It is staying there so that it shows up in dietpi-services which is just confusing

Extra details

  • I deleted the pihole-FTL.service myself so that it doesn’t show up in dietpi-services anymore

Did it also remain after a reboot?

I’m not sure if I rebooted directly after the uninstall using dietpi-software. But I did once I tweaked some overclock settings and it remained.

The same thing is happening on my Raspberry Pi 2. I used PiHole there, liked AdGuardHome better so I migrated to that and now I am migrating that AdGuardHome to my Raspberry Pi 1 since I am running out of RAM on my Rpi2.

Screenshot of Rpi2 where I haven’t deleted pihole-FTL.service manually yet:

Probably an issue we might need to report to PiHole developer directly. It’s their service and usually they need to remove it as well.

I guess @MichaIng knows because he supported PiHole developer on implementing this feature.

I guess when the systemd unit was added, it was forgotten to be added to the uninstaller as well. Since I added the systemd unit, my fault :sweat_smile: (despite reviewers from Pi-hole team could/should have recognised as well).

Ok. Was it fine to just delete the pihole-FTL.service or did I have to remove those override configs as well?

simply go to remove the override config directory. To be on save side.

rm -Rf /etc/systemd/system/pihole-FTL.service.d

Thanks, that folder wasn’t there anymore. I’m not sure if I deleted it myself or if it was gone with the uninstall using dietpi-software.

It’s an optional folder, not necessarily available on all systems. Typically, it just become available if you create overrides yourself.

or if you do tweaks with dietpi-services. Without the service file itself, the override config dir does no harm, so this is just for complete cleanup.