pie 4 hangs at empty screen


installed a new pie 4. All went well. Installed some basic apps.
Then I changed eth0 settings (static) and upon reboot I get a blinking cursor instead of the login prompt at the console (hdmi)
The ip settings were applied and I can ssh into it and get the console.
But the physical console stops at the blinking cursor.

Changing back to dhcp doesn’t change this.

This is my 2nd pie and the first one didn’t show this issues (Installed under dietpie 6).

Any ideas?

It stops after “…waiting for valid network connection…”

did you change anything in config.txt?


I have now installed from fresh image 3 times.

I’ve nailed it down to LXDE. Once I install this and reboot I get the blinking cursor in pysical console…
When I ssh into it and uninstall LXDE it boots alright again.

This is what I have in config.txt:

# Docs: https://www.raspberrypi.org/documentation/configuration/config-txt/

# If you get no picture, set the following to "1" to apply most compatible HDMI settings.

# Uncomment to adjust the HDMI signal strength if you have interferences, blanking, or no display.
# - Values from "0" to "11" are allowed, use values above "7" only if required, e.g. with very long HDMI cable.
# - Default on first RPi1 A/B is "2", else "5", on RPi4 this setting is ignored.

# Uncomment if HDMI display is not detected and composite is being outputted.

# Uncomment to disable HDMI even if plugged, e.g. to force composite output.

# Uncomment to force a console size. By default it will be display's size minus overscan.

# Uncomment to enable SDTV/composite output on RPi4. This has no effect on previous RPi models.
# SDTV mode

# Uncomment to force a specific HDMI mode (this will force VGA).

# Uncomment to force an HDMI mode rather than DVI. This can make audio work in DMT (computer monitor) modes.

# Set "hdmi_blanking=1" to allow the display going into standby after 10 minutes without input.
# With default value "0", the display shows a blank screen instead, but will not go into standby.
# NB: With "1" some applications (e.g. Kodi, OMXPlayer) cannot prevent display standby due to missing DPMS signal.

# Set to "1" if your display has a black border of unused pixels visible.

# Uncomment the following to adjust overscan. Use positive numbers if console goes off screen, and negative if there is too much border.

# Rotation

#-------RPi camera module-------

#-------GPU memory splits-------

#-------Boot splash screen------

#-------Onboard sound----------



# NB: Enabled for 1st run only. If you want to keep this setting, please set CONFIG_SERIAL_CONSOLE_ENABLE=1 in dietpi.txt before 1st boot.




did you have set LXDE to autostart? What image are you using? 64bit or 32bit?


No it was not set to auto start. It should start to the normal login prompt.
I used the 32 bit image.

I have now a virgin installed and running installation, with some apps installed but before LXDE.
I have made a dietpi-backup to be easily revertable.

So if you need any config files before LXDE install and after another installation let me know.

ok, I’m able to replicate. Let me check with developer.

If you don’t mind, can you try following once LXDE was installed

/boot/dietpi/func/dietpi-set_hardware rpi-opengl vc4-kms-v3d-pi4

Sorry I don’t quite understand.
Do you mean to reinstall and then run this command?

if you find time, install LXDE again and execute the command followed by a reboot.

OK did that.

After the first reboot it booted into the (I think) LXDE login instead of normal console. (I had not changed the startup options when asked after the install).
With dietpi-config I selected autostart to manual-login.
Rebooted again.

This time all went well. Rebooted to manual login with the normal screen showing.

So there seems to be a bug with the install:

  1. autostart is changed
  2. something else requiring the command you provided.

thx for verifying this. I had same experience with the changed login method.

It is reported to the developer already. https://github.com/MichaIng/DietPi/issues/4175#issuecomment-793836203

Looks like running /boot/dietpi/func/dietpi-set_hardware rpi-opengl vc4-kms-v3d-pi4 is fixing the xserver start (independent from the login method change/bug).

Great you could confirm this all. Yesterday I spent 4 hrs around this until resorting to the forum :cry:

I guess this will be completely fixed by a dietpi update, which when released I need to install to get the fix.


yes it will be fixed on next update. But you already have all you need :wink:

Login method is back to manuell and your system is booting as it should be. As well you have the secret command executed to fix the xserver start :smiley:

/boot/dietpi/func/dietpi-set_hardware rpi-opengl vc4-kms-v3d-pi4


Issues resolved with: https://github.com/MichaIng/DietPi/commit/7e8046c2404f37d1c03ad55729747a57ef85458f
Changelog: https://github.com/MichaIng/DietPi/commit/880182ddcfd9a06661c5f08e8d578aa083d4a7c9

Many thanks for reporting :slight_smile:.

You’re welcomed. Was a head scratcher!

Waiting for 7.1 now.

will take a while as we released 7.0 a week ago :sunglasses: