Pi4: DietPi on sole external SSD

hi everyone,

Is it now possible to run DietPi on a single SSD drive attached to USB (ie: without a microSD card) of a Raspberry Pi 4? How?


well the question is not if you can boot DietPi on a RPi4 from an extern SSD.

The question is, if you can boot Raspbian Lite on a RPi4 using an external SSD :wink:

Answer: Not yet. see > https://www.raspberrypi.org/documentation/hardware/raspberrypi/booteeprom.md

The feature will come and there is already an available beta firmware out. However not yet official released. As well a first guide how to use the beta version is out on the web. Maybe you like to have a look. But this is all without guaranty as it’s still beta



And one more linkt to a similar topic on GitHub


Thank you for that quick reply and useful links.

So I guess the big question is: will DietPi be updated when the final EEPROM comes out? (new version of Raspbian I suppose)?


the OS below DietPi is a Raspbian Lite (base image) in case of RPi devices. Therefore the eeprom update service is already there and updates will be applied during boot, if available.

root@DietPi4:~# journalctl -u rpi-eeprom-update
-- Logs begin at Sat 2020-05-23 10:25:50 CEST, end at Mon 2020-05-25 16:47:33 CEST. --
Mai 23 10:25:51 DietPi4 systemd[1]: Starting Check for Raspberry Pi EEPROM updates...
Mai 23 10:25:51 DietPi4 rpi-eeprom-update[249]: BCM2711 detected
Mai 23 10:25:51 DietPi4 rpi-eeprom-update[249]: BOOTLOADER: up-to-date
Mai 23 10:25:51 DietPi4 rpi-eeprom-update[249]: CURRENT: Thu 16 Apr 17:11:26 UTC 2020 (1587057086)
Mai 23 10:25:51 DietPi4 rpi-eeprom-update[249]:  LATEST: Thu 16 Apr 17:11:26 UTC 2020 (1587057086)
Mai 23 10:25:51 DietPi4 rpi-eeprom-update[249]:  FW DIR: /lib/firmware/raspberrypi/bootloader/critical
Mai 23 10:25:51 DietPi4 rpi-eeprom-update[249]: VL805: up-to-date
Mai 23 10:25:51 DietPi4 rpi-eeprom-update[249]: CURRENT: 000137ad
Mai 23 10:25:51 DietPi4 rpi-eeprom-update[249]:  LATEST: 000137ad
Mai 23 10:25:51 DietPi4 systemd[1]: Started Check for Raspberry Pi EEPROM updates.

Probably you would need to set rpi-eeprom-update to stable. By default it’s set to critical

root@DietPi4:~# cat /etc/default/rpi-eeprom-update

detailed information can be found at the bottom of the page https://www.raspberrypi.org/documentation/hardware/raspberrypi/booteeprom.md

Just a word of caution to people trying this.

I have tried it this morning and managed to boot from a 1TB HD. The initial resize2fs took quite some time (5 minutes?), but afterwards DietPi booted up just fine (v6.3).

The problem came later when I configured DietPi with root access. I tried to install a couple of packages, and on the next reboot, I got an error and the Pi didn’t start on USB HD anymore. I think the problem was that the packages/script erased some necessary files like recovery.elf and recovery4.elf (which were stated as not found on the screen), and also start4cd.elf which was stated as not compatible.

So I am unsure which script changed these files, but be aware of these issues.

I really do not understand why folk want to do this. Other than freeing up an SD Card it has zero benefit AFAICS. I usually transfer the boot folder to an old, small (2GB) SDCard once the transfer of the rootfs has been done and boot from that.

Did you have done a reboot right after you updated to 6.30??

It was a fresh install directly from USB (no SD card used).

After the initial config, yes, it asked for a reboot, and that’s when some files were changed on the HD.

well during initial setup, a couple of Raspbian/Debian package update procedures will be called. Maybe it will revert (beta) changes you have done to get USB booting up?

Now that this boot from USB firmware is official and stable, is it safe to use with DietPi 6.3 to avoid the problems discussed above?

according official Raspberry documentation, it’s still not released for RPi4



Oh - I was under the impression its out of Beta status as when you switch the config to ‘stable’ its installable.

Note that likely you need to update the EEPROM itself as well before you can do the USB boot, e.g. via dietpi-config > Advanced Options. I also though it was already possible with current version, probably I mixed it up while investigating the new 5.4 kernel in pipeline. Can’t check, GitHub is down :frowning:.

After updating your EEPROM you might want to test the new 64-bit image: https://dietpi.com/downloads/images/
Some RPi specials might not yet work, beta state as well from RPi Foundation side, but many mid- and long-term benefits over 32-bit Raspbian-based image I expect :slight_smile:.

that’s the latest status

2020-06-17 Promote 2020-06-15 to STABLE

  • Promote the latest beta EEPROM and recovery.bin to stable and feature freeze USB MSD support until a production release is ready.