Pi4 and Teamviewer

I have setup my pi3b+ and teamviewers works without problem, but when i do the same on the pi4, i get the server up and running also the teamviewerd.service and all but when launching the conection from another pc/phone i got error Waitforconnectfailed.

Is there any workaround?

how do you setup the teamviewer? I just like to know, that I’m able to test.

sure, these are the lines that i used

sudo apt-get update
sudo apt-get upgrade
wget https://download.teamviewer.com/download/linux/teamviewer-host_armhf.deb
sudo dpkg -i teamviewer-host_armhf.deb
sudo apt --fix-broken install
sudo teamviewer passwd test123
teamviewer info

Get the ID and thats all. I did this step over an over on my pi3b+ and no problem, everything seems to works fine. But on pi4, the pi4 will be displayed has on in your client but cannot connect.

ok I was playing with it on DietPi as well as on plain Raspbian Lite. For me it has issues on both OS. So I’m not able to run it on a RPi4 at all. At least a little bit of expected as the pre-image for RPi devices is Raspbian Lite. Question is why it is not working on a RPi4 but on a RPi3. On the web I found an entry on teamviewer forum pointing the same direction. Unfortunately there was no reaction on the board.

https://community.teamviewer.com/t5/Linux/Raspberry-Pi-4-Buster-Teamviewer-will-not-start-up-and-can-t-do/td-p/75835#

Thanks bro, i will keep trying when another version comes out.

Maybe you can try to connect to the topic created on teamviewer forum. Probably it can create a reaction if more people report on it.