Pi-Hole

Hi guys,

I’m trying to setup DietPi with Pi-Hole and I’m running into some errors.
I see in my SSH client that during the Pi-Hole installation, it fails and closes. Then after a short while it just ends the installation. The only information I get is this:

When trying to install DietPi without Pi-Hole, it seems to hang during the install of Google AIY voice kit. I’m failing to get a connection to that server.

Let me know what I’m doing wrong or if any additional information is needed. Thanks for the help.

Hi,

you have no internet connection or DNS resolution on your device.
Check your network settings.

My internet connection and DNS settings are fine as far as I can tell. I have it set to DHCP. I ran the internet connection test under network settings and it’s resolving fine. I did notice on github someone did post that Google AIY voice also was not resolving due to an empty hostname. That doesn’t solve the Pi-hole issue as to why it failed to install though. Thanks for the suggestion though.

Hi,

first: you are on a “old” and unsupported version now.
DietPi v6.0 is out: DietPi/CHANGELOG.txt at master · Fourdee/DietPi · GitHub

Extra check pihole installation on RPi Zero (HW_MODELL:1) here right now on a fresh image: DietPi_v6.0_RPi-ARMv6-Stretch.img

Works like a charm, without errors.

 ───────────────────────────────────────
 DietPi     | 10:15 | Mon 29/01/18
 ───────────────────────────────────────
 v6.0       | RPi Zero W (armv6l)
 ───────────────────────────────────────
 IP eth0    | 192.168.10.100
 ───────────────────────────────────────



root@RPi-Zero:~# dietpi-services status
[  OK  ] Root access verified.

 DietPi-Services
─────────────────────────────────────────────────────
 Mode: status

[  OK  ] cron   active (running) since Mon 2018-01-29 10:15:39 CET; 10min ago
[  OK  ] lighttpd       active (running) since Mon 2018-01-29 10:15:40 CET; 10min ago
[  OK  ] php7.0-fpm     active (running) since Mon 2018-01-29 10:15:51 CET; 10min ago
[  OK  ] dnsmasq        active (running) since Mon 2018-01-29 10:15:53 CET; 10min ago
[  OK  ] pihole-FTL     active (running) since Mon 2018-01-29 10:15:54 CET; 10min ago

Never used Google AIY voice kit and support for it is very new.
Have never installed it. Don’t have the hardware for it on my RPi Zero.
Don’t know, if it is a good choice in combination with PiHole …

I had a problem with PiHole trying to access internet during install, although not like this. What fixed it for me was setting actual nameservers instead of 127.0.0.1 in static IP configuration