Pi-Hole update process

I have a Raspberry Pi 2 that, using DietPi, I run both Pi-Hole and a Plex Server on. Through the Pi-Hole web administration interface, I see there is a pending update to Pi-Hole. The command to perform this update is “pihole -up” from the command line. I had a problem with this once and had to reinstall everything. So, before I try updating Pi-Hole through the command line again, I’d like to ask if it will work given I installed the Pi-Hole using dietpi-software?


All I can say is it works for me. Not too hard to reinstall if it doesn’t work?


same here in v159
Pihole command pihole -up returns error
something about path var/www/pihole … …/admin
I had to reinstall

Yup, happened to me too a few days ago. It was a pretty fresh install with only pihole and Kodi so wasn’t a big deal to reinstall, and I have no idea what happened, but pihole’s web interface wasn’t working anymore and I also couldn’t use the -up command as above

According to Pi-hole Details

Updating PiHole:

PiHole overwrites the lighttpd.conf during updates, so please backup your lighttpd.conf before updating:

Backup lighttpd.conf

mv /etc/lighttpd/lighttpd.conf /etc/lighttpd/lighttpd.conf.bak

> **_PiHole can then be updated by running_**
> ```text
pihole -up

Restore lighttpd.conf

mv /etc/lighttpd/lighttpd.conf.bak /etc/lighttpd/lighttpd.conf


so maybe that was the problem?

I actually performed the steps in gpioneer’s reply to backup lighttpd.conf prior to updating. I ran pihole -up and I get the following errors about five minutes into the update:

Error: Could not update local repository. Contact support.

Unable to complete update, please contact Pi-hole Support

Pihole, including the web interface, is left in working order, but the update is not complete. It’s a little frustrating and definitely confusing given that Pihole is such well-designed software that the update process doesn’t quite work smoothly. I haven’t yet tried to uninstall and reinstall through dietpi-software, but I think that is the next step.

Same error here.

I sorted out how to do the pi-hole update with dietpi without error. I posted the info on a different forum (Pi-hole forum). Here is the link:

The process is straightforward and works.