Pi-hole running Dietpi on a Rpi 1B adlist not working

I tried to add this to my adlist: * https://zerodot1.gitlab.io/CoinBlockerLists/hosts_browser

It’ll give me this messsage “Adlist was inaccessible during last gravity run” I can click on the link and navigate to the website.

I’ve whitelisted the domain just in case.

I’ve put in the terminal
curl https://zerodot1.gitlab.io/CoinBlockerLists/hosts_browser
and I get this back
curl: (18) HTTP/2 stream 1 was not closed cleanly before end of the underlying stream

Strangely I can add the adlist when I setup the card using Raspberry Pi OS Lite 32-bit. Same SDcard and same Raspberry Pi. Only difference is DietpiOS and Raspberry Pi OS Lite 32-bit.

I’m using a Rpi 1B and using the ARMv6 version of the Dietpi OS.

I installed it on 2 different cards.
#1 Silicon Power 32GB 3D NAND High Speed MicroSD Card
#2 SanDisk 32GB SD Card

Works here on a RPi 4 :thinking:

Can you run pihole -g on CLI and have a look for error messages?

[i] Target: https://zerodot1.gitlab.io/CoinBlockerLists/hosts_browser
[✗] Status: Connection Refused
[✗] List download failed: no cached list available

This usually means firewall or some other blocker. Other feeds work properly?

You probably ran into this bug:

Do you created a .sqliterc file?

hmm I’m using this list since years

As well it is automatically manged by my pihole-updatelists tool

Yes I have maybe 11 other adlists that are working fine. It’s just this one from zerodot1.github.io that’s getting this error.

Yes it worked for me on a different Raspberry Pi 1B when I was using the Raspberry Pi Lite OS as well. Seems to be happening only when I use Dietpi OS. I’ve tried it 3-4 times with Dietpi and this error keeps happening.

working fine on my DietPi system

Sorry I’m new to all this so I do not think I created a .sqliterc file. I just follow the Dietpi script and it installed Pihole for me.

can you check

ls -la /root/

This is what I got back

total 24
drwx------  3 root root 4096 Jan 14 02:13 .
drwxr-xr-x 18 root root 4096 Dec 31 01:51 ..
-rw-------  1 root root   94 Jan 17 01:38 .bash_history
-rw-r--r--  1 root root  571 Jul 29 07:05 .bashrc
-rw-r--r--  1 root root  161 Jul 29 07:05 .profile
drwxr-xr-x  2 root root 4096 Dec 31 01:49 .ssh

just tested this on 3 different DietPi systems RPi4, Orange Pi 5 and Orange Pi Zero 3. It’s working well on all 3 systems. Did you install anything else on your systems?

It works fine on my 3 dietpis as well.
Let’s see if something else was installed on the system.

1 Like

I didn’t install anything else. I just followed these instructions.

The only difference is webserver preference is Apache during the setup.

Maybe it’s how I setup Dietpi OS since the Raspberry Pi OS lite this isn’t a problem?

would it be possible to flash a new DietPi image and complete the initial setup with default values. Once done just try to fetch the list

curl https://zerodot1.gitlab.io/CoinBlockerLists/hosts_browser

Ugh I made a new SDcard twice now and I’m still getting the same issue. Same error when I did the curl.

curl: HTTP/2 stream 1 was not closed cleanly before end of the underlying stream

I doubt it’s an issue with DietPi or the installation as we tested this on a larger number of various systems without issue.

If you remove the dietpi user group, Pi-hole doesn’t work.

And how is your comment related to the issue not being able to fetch a list using curl? Even without PiHole being installed, curl should work.