Pi 4 not booting

I installed Logitech Music Server onto my Pi 4 tonight and during reboot it stalled - it does this when I try to reboot with the Dragonfly Black DAC connected. I forgot to pull the DAC before rebooting.
Now I can’t get it to boot at all. I’m running DietPi (Debian buster) and have moved the root file system to the attached USB 3 external hard drive.
What should my troubleshooting steps be?

Connect a screen to see what error messages it give

There is a screen connected and it shows nothing.
There is a little activity on the green led after connecting power but then nothing.

there is a Sticky at raspberrypi.org giving an indication on what could happen.

As well some LED warning flash codes

With no card inserted I get 4 green led blinks in a repeating sequence. This means my eprom is ok but the bootloader is not working correctly.
There are instructions to try to repair it.
Before I follow those is it an option to upgrade the firmware now that 2020-06-15 EEPROM is regarded as stable? Can I do that and boot from my HDD without changing the data on the HDD?

First I would try to fix the issue with the system before changing other thinks. Usually EEPROM will be updated automatically if needed.

Btw: 4 times blinking is indicating that your bootloader is working correctly.

Is the bootloader working correctly?
To check that the bootloader is working correctly, turn off the power, unplug everything from the Raspberry Pi 4, including the SD card, and then turn the power back on. If the green LED blinks with a repeating pattern then the bootloader is running correctly, and indicating that > start*.elf > has not been found. Any other actions imply that the bootloader is not working correctly and should be reinstalled using > recovery.bin> .

LED warning flash codes

Long flashes Short flashes Status
0 4 start*.elf not found


Do you have a spare SD card to test?

I have another SD card but what should be on it? A fresh copy of the DietPi image?


So I tried it with a fresh DietPi image and still it would not boot.

hmm this doesn’t sound promising. Can you try with a plain Raspbian Lite if this is booting?

Same result again. I’ll buy a new sd card later today but that card seems to be working fine
Here’s a short clip showing the LED activity when power is applied with a fresh rasping lite on the card

honestly I’m not sure how many flashes are this. Do you have any USB device connected? If yes, maybe you can remove them and try again. But if even Raspbian is not booting, something wrong on your device.

No. There is nothing else connected.
Where to from here?
I guess I need to try my new sd card and then try recovery on the eprom

tried the new sd card with Raspian Lite and same result.
Then I followed the eprom recovery instructions (which seemed to work fine), to double check the eprom is ok
LED activity is exactly the same as in the above video

Basically you could try to place your problem on a Raspberry Pi specific board. Maybe there someone has an idea why your SBC is not booting anymore. Probably there are some hardware issues?