PC version Nvidia trouble

Been trying to get this solved for a few hours now. Basically when installing the Nvidia driver DietPi seems to take issue with my 750Ti and gives an xconf related “no screens found” error whenever trying to do startx.

Now, on FreeBSD and another Linux distro I happen to know the solution to this is to add nvidia-modeset_load=“YES” in /boot/loader.conf but this doesn’t work with DietPi. Any way to invoke it or anyone know of the solution…?

So having failed repeatedly with the dietpi built-in-installer option… AND ITS GOOD NEWS.
I found debian instructions, which happen to work perfectly and I now have an apparently fully working Nvidia DietPi install!
For anyone who has trouble with Nvidia drivers under the PC version of DietPi, follow this short guide TO THE LETTER (only substitute the Nvidia driver it tells you to download for the latest current driver for your card);

http://www.allaboutlinux.eu/remove-nouveau-and-install-nvidia-driver-in-debian-8/1/

No idea if this could be implemented by DietPi itself in some way but obviously a huge difference to the apparently non-working current installer included. Kodi now works, for example, which doesn’t under Nouveau! Hope it helps someone!

Hi,

Thanks for the info.

I personally tested with 1050Ti successfully with DietPi.
Seems nouveau is the issue here, we’ll add this to DietPi and disable by default during nvidia install:
https://github.com/Fourdee/DietPi/issues/1244

Hi,

We’ve applied the fix for DietPi v159, would you be willing to test for us?
https://github.com/Fourdee/DietPi/issues/1244#issuecomment-345530450

I will try to do so today, time permitting.

Having done the update to 159, and doing nothing other than installing the Nvidia driver and lxde (then a reboot), startx, and looking at Nvidia server settings within lxde it states that Nouveau is still being used, and to logout and do nvidia-xconfig. This then results in the same no screens error as before. Being slowed somewhat with testing as limited to wifi right now for unrelated reasons, but happy to take another look as needed.

Thanks for testing.

Can you please verify latest testing branch code is in use:

cat /etc/modprobe.d/blacklist-nouveau.conf

Should return:

blacklist nouveau
 blacklist lbm-nouveau
 options nouveau modeset=0
 alias nouveau off
 alias lbm-nouveau off

Yep, all those commands are indeed in there.

Strange looks fine. If the module is blacklisted, it shouldn’t be possible for it to be available to system.

Could be possible we need to reboot after running “update-initramfs -u”, to ensure new settings are loaded by system. Maybe the Nvidia driver install is loading current env settings, then overwriting the initramfs we previously generated.

Might be worth us blacklisting “nouveau” by default on the image, this might resolve the issue.

Ok, i’ve sent the commit for:
nouveau now blacklisted by default on all our x86_64 systems, preferring official Nvidia driver:
https://github.com/Fourdee/DietPi/issues/1244#issuecomment-346902934

Gets blacklisted during dietpi-update on testing branch. If you would be willing to test again for us, i’d really appreciate it.

I will try to do so within the next few days.

Still seeing the same behaviour as before unfortunately. Same note in lxde when running nvidia settings about not using the nvidia driver, log out and do nvidia-xconfig, which then results in the no screens error. I think I saw it mention nouveau being loaded/conflicting when the actual Nvidia installer from the dietpi menu was run at one point but can’t swear to it and don’t even know if that was relevant. I’m a little limited by crappy wifi at the moment so testing isn’t the quickest process in the world to begin over, but still happy to keep trying here as it’s obviously a big difference when it works.

(The difference between having a DietPi-toting PC that will happily play back x265 4K and not. Very fun to see after using the Pi version for so long!)