PC uefi broken after trying to install dietpi

I have a core2duo i tried to install uefi version of dietpi on.
it has uefi bios so…well after the first boot I walked away while it was updating and it kernel panic’d
I rebooted and got the >grub prompt.

re-installed and watched it.
it kernel panic’d while installing the x86-64-efi-platform.

now I have “debian” listed as my first two boot entry in the boot selection screen and i cannot get them out.
so even if i manage to boot from usb manually and install any OS including diet pi native bios…i can’t boot from it.
all i get is “boot succeeded - debian”

I assume there is something not quite standard about this old PC’s uefi bios because now that I think about it the last few linux distro’s I tried on it didn’t boot in uefi mode and live linux distro’s didn’t boot with uefi either.

i’ve pulled the battery, unplugged and did the bios jumper thing for 15 mins.
double debian still there.

any ideas on how to fix this?
I tried booting up a fresh copy of the uefi version but unplugging the network cable so I could get to a command prompt and try efibootmgr but i’m not a linux guru and the command prompt didn’t acknowledge any commands.

any ideas?
Maybe installing win10 and running the uefi tool?