Owncloud - Storage Temporarily not available

Before you advise, please note that I am a noob with Linux and raspberry pi. I’ve installed software on it just be reading instructions online and don’t understand what most of the commands actually do. I have dietpi installed on my raspberry pi 4. I have added my samba drive in external storage but i try to open it in owncloud, i get an error ‘Storage is temporarily not available’.

i am happy to share my setting and logs if someone can tell me the commands to do it. Thank you.


many thanks for your message. Not sure what kind of software you installed but owncloud is available via dietpi-software catalogue. It’s already pre-configured and there is no need to hack any commands into command line :wink:

I tried to replicate you scenario but for me it is working well.

  1. I installed owncloud
  2. login as admin
  3. going to admin > settings > administration > storage
  4. activated external storage
  5. select SMB / CIFS
  6. specified SAMBA server IP, samba share, user, password
  7. my share was listed as green immediatly
  8. going back to folder view
  9. and verified the access to my samba share with success

Maybe you can have a look to /mnt/dietpi_userdata/owncloud_data/owncloud.log for some error message. Be careful, the file could be hard to read.

thanks. the sambs config in owncloud was not correct. fixed it, works like a charm.

just to avoid a misunderstanding. You are trying to add a SAMBA share from the same server OwnCloud is running on?