ownCloud External Storage


I am trying to set up external storage with ownCloud however, I get “You don’t have permission to upload or create files here” when I try to do anything with it. I have tried setting chmod -R 777 on the parent folder and followed the install guide on the forums for ownCloud but I’m really at a loss. I’d quite like to replace the Samba share with something a little snazzier!

Thanks in advance.


If the USB drive contains your DietPi user data (https://dietpi.com/forum/t/dietpi-software-user-data/400/1), permissions would of been applied during the file transfer. If not, try applying the permissions again with:

/DietPi/dietpi/dietpi-software setpermissions

The above will only apply permissions to the DietPi user data location and /var/www, so if you have manually changed the Owncloud data location (eg: not using DietPi tools to move user data), you’ll need to manually set permissions:

chown -R www-data:www-data /path/to/owncloud/data

Cheers Fourdee, changing ownership seems to have worked!