Owncloud admin password

hi all.

i just installed DietPi for the first time and a bunch of software, including owncloud, on a RPi3

The info on the application page say that the default password for admin should be “dietpi” ( https://dietpi.com/forum/t/dietpi-software-details-for-all-installation-options/22/6 ) but I can’t login.

What is the correct default password?


After some experimentations I was able to change the password with owncloud’s cli tools and login.

There’s still something wrong in my system though. I can’t perform many of the administration tasks in owncloud, such as adding and configuring external storage shares. I have to resort to the cli for these.

Plus, I also had to change the default password for FreshRSS. too, before I could login.

Could it be that something went wrog during system installation?

When you logged into the DietPi system the first time, you were asked to enter a new global software password. This one is used as default password for installed software then. We have to make this clearer in the online docs I think :thinking:.

Could you give some details, which steps you did on the web UI and which errors you faced? So we can try to replicate. The web UI should allow everything that you can do via occ command as well.

Hi and thank you.

I’ll try to reconstruct what I did from the command history.

Basically, after changing the password with occ resetpassword admin I was able to login.

The problem then is that even if Owncloud’s web interface shows me ad an admin and allows me to enter the rstricted areas, it seems as every action or change I do in the external storage area is silently ignored.

If I choose a new storage backend in the external storage page, for example, I’d expect the fields to configure the backend to appear, but nothing happens.

If I do the whole setup using the command line then I see the entries appearing on the page.

BTW, I don’t see any save or commit button on the page. I think it should work exactly as the user management page where changes are subittes as soon as you leave a field.

Remember to give www-data user permissions to any external dir that you add: chown -R www-data:www-data /path/to/external/directory

Not sure why backend related settings do not show up when enabling via web UI. You could try ctrl+F5 to clear browser cache and reload the page.

The external folders I added are an USB storage drive, that’s mounted by root with permissions 777 and 3 SMB shares mounted as dietpi user using the config wizards.

Unfortunatey I’m still experiencing issues. For example I noticed that owncloud does not show me via the web interface the current situation of files and folders in the shared areas. It’s all “frozen” at the date I created the shares, unless I run the cli tool to force a scan. It seems owncloud does not “sync” it’s database.

Is there a way to completely uninstall and reinstall owncloud using DietPi wizards? I’d be ok with that, if that could fix the situation once and for all, instead of trying to pinpoint the problem.

You can uninstall and reinstall ownCloud, but no guarantee that this fixes the issue. I never tried ownCloud with external storages, just remember that the internal scanner of Nextcloud includes external storages as well.

However if you want to try it: dietpi-software uninstall 47
This does not remove the ownCloud data and creates a backup of the datebase. Both would be migrated if you install it again.
So if you want to start completely fresh: rm -R /mnt/dietpi_userdata/owncloud_data
Then to install again: dietpi-software install 47

If access to the external storages otherwise works well now, including manual files scanning, you might want to ask the ownCloud community if this is expected or how to debug/enable automated database updates for external storages: https://central.owncloud.org/
If there is an easy solution, we would implement this into our install script as well.