OpenVPN not working on MacOSX ??

Hi everybody,

I’ve been struggling for some time now to get OPENVPN functioning - it’s installed on a Raspberry Pi B+ and I am trying to access it via a Mac.

Having followed the installation instructions; set up a noip domain; amended the certificate with correct noip domain and forwarded the relevant ports (on my Virgin Media ‘Super Hub’) I have then installed Tunnelblick and imported my .ovpn certificate. Upon connecting to my Pi via TUNNELBLICK the connection appears to be successful however I get the following (seemingly vague) error:

This computer’s apparent public IP address was not different after connecting to DietPi_OpenVPN_Client. It is still XX.XXX.XXX.XXX.
This may mean that your VPN is not configured correctly.

(actual IP address replaced)
I have tried this on my local network (Virgin Media ‘Super Hub’) as well as whilst hotspotting from my mobile phone - I get the same error regardless.

Could it be an issue with the router? or the fact that I am trying to access via a Mac? Using the same certificate on my android phone via the OpenVPN app also doesn’t change the IP…

Any help greatly GREATLY appreciated guys! I am usinf DietPi successfully on another Pi and just love it’s useability and simplicity :smiley: , thank you!